###!!! ASSERTION: cache check failed: 'NS_SUCCEEDED(rv)', file r:/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 333

RESOLVED WORKSFORME

Status

()

Core
Networking
P5
normal
RESOLVED WORKSFORME
13 years ago
2 years ago

People

(Reporter: timeless, Unassigned)

Tracking

({assertion})

Trunk
x86
Windows XP
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
###!!! ASSERTION: cache check failed: 'NS_SUCCEEDED(rv)', file r:/mozilla/netwerk/protocol/http/src/
nsHttpChannel.cpp, line 333
Break: at file r:/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 333
 	xpcom_core.dll!nsDebugImpl::Break(const char * aFile=0x012dae50, int aLine=0x0000014d)  Line 
309	C++
 	xpcom_core.dll!nsDebugImpl::Assertion(const char * aStr=0x012dc604, const char * 
aExpr=0x00000004, const char * aFile=0x012dae50, int aLine=0x0000014d)  Line 290
	C++
 	xpcom_core.dll!nsDebug::Assertion(const char * aStr=0x012dc604, const char * 
aExpr=0x012c3168, const char * aFile=0x012dae50, int aLine=0x0000014d)  Line 109
	C++
>	necko.dll!nsHttpChannel::Connect(int firstTime=0x01062488)  Line 333 + 0x1e
	C++
 	necko.dll!nsHttpChannel::AsyncOpen(nsIStreamListener * listener=0x03e7a508, nsISupports * 
context=0x00000000)  Line 3097 + 0x9	C++
 	imglib2.dll!imgLoader::LoadImage(nsIURI * aURI=0x03e7a508, nsIURI * 
aInitialDocumentURI=0x00000000, nsIURI * aReferrerURI=0x80000000, nsILoadGroup * 
aLoadGroup=0xffffffff, imgIDecoderObserver * aObserver=0x01062488, nsISupports * 
aCX=0x0012f500, unsigned int aLoadFlags=0x01e05870, nsISupports * cacheKey=0x00000000, 
imgIRequest * aRequest=0x03e7a508, imgIRequest * * _retval=0x00000000)  Line 510 + 0x10
	C++
 	gklayout.dll!nsContentUtils::LoadImage(nsIURI * aURI=0x02f4a460, nsIDocument * 
aLoadingDocument=0x036ae2a0, nsIURI * aReferrer=0x03257860, imgIDecoderObserver * 
aObserver=0x030774c4, int aLoadFlags=0x00000000, imgIRequest * * aRequest=0x030774c8)  Line 
1771 + 0x24	C++
 	gklayout.dll!nsImageLoadingContent::ImageURIChanged(const nsACString & aNewURI={...})  Line 
478 + 0x29	C++
 	gklayout.dll!nsImageLoadingContent::ImageURIChanged(const nsAString & aNewURI={...})  Line 
411 + 0x14	C++
 	gklayout.dll!nsHTMLImageElement::SetParent(nsIContent * aParent=0x00000000)  Line 634
	C++
 	gklayout.dll!nsGenericElement::AppendChildTo(nsIContent * aKid=0x00000000, int 
aNotify=0x00000000, int aDeepSetDocument=0x00000000)  Line 2569
	C++
 	gklayout.dll!SinkContext::AddLeaf(nsIHTMLContent * aContent=0x030774a8)  Line 1564
	C++
 	gklayout.dll!SinkContext::AddLeaf(const nsIParserNode & aNode={...})  Line 1496
	C++
 	gklayout.dll!HTMLContentSink::AddLeaf(const nsIParserNode & aNode={...})  Line 3126
	C++
 	gkparser.dll!CNavDTD::AddLeaf(const nsIParserNode * aNode=0x0329b978)  Line 3760 + 0xd
	C++
 	gkparser.dll!CNavDTD::HandleDefaultStartToken(CToken * aToken=0x03e68a50, nsHTMLTag 
aChildTag=eHTMLTag_a, nsCParserNode * aNode=0x0329b978)  Line 1432 + 0x8
	C++
 	gkparser.dll!CNavDTD::HandleStartToken(CToken * aToken=0x00000034)  Line 1807 + 0xe
	C++
 	gkparser.dll!CNavDTD::HandleToken(CToken * aToken=0x00000034, nsIParser * 
aParser=0x02cd91c8)  Line 992 + 0xa	C++
 	gkparser.dll!CNavDTD::BuildModel(nsIParser * aParser=0x02cd91c8, nsITokenizer * 
aTokenizer=0x03acf280, nsITokenObserver * anObserver=0x00000000, nsIContentSink * 
aSink=0x039f3510)  Line 471 + 0xa	C++
 	gkparser.dll!nsParser::BuildModel()  Line 1919	C++
 	gkparser.dll!nsParser::ResumeParse(int allowIteration=0x00000001, int 
aIsFinalChunk=0x00000001, int aCanInterrupt=0x00000001)  Line 1784 + 0x6
	C++
 	gkparser.dll!nsParser::ContinueParsing()  Line 1362 + 0xc
	C++
 	gkparser.dll!nsParser::HandleParserContinueEvent()  Line 1426
	C++
 	gkparser.dll!nsParserContinueEvent::HandleEvent(PLEvent * aEvent=0x034c4498)  Line 237
	C++
 	xpcom_core.dll!PL_HandleEvent(PLEvent * self=0x034c4498)  Line 693
	C
 	xpcom_core.dll!PL_ProcessPendingEvents(PLEventQueue * self=0x01062b08)  Line 628
	C
 	xpcom_core.dll!nsEventQueueImpl::ProcessPendingEvents()  Line 395
	C++
 	gkwidget.dll!nsWindow::DispatchPendingEvents()  Line 3721
	C++
 	gkwidget.dll!nsWindow::ProcessMessage(unsigned int msg=0x00000201, unsigned int 
wParam=0x00000001, long lParam=0x00b401a8, long * aRetValue=0x0012fce8)  Line 4092
	C++
 	gkwidget.dll!nsWindow::WindowProc(HWND__ * hWnd=0x001126e6, unsigned int 
msg=0x00000201, unsigned int wParam=0x00000001, long lParam=0x038b264c)  Line 1355 + 0x10
	C++
 	user32.dll!77d43a50() 	
 	user32.dll!77d43b1f() 	
 	user32.dll!GetMessageW()  + 0x125	
 	user32.dll!DispatchMessageW()  + 0xb	
 	appshell.dll!nsAppShellService::Run()  Line 484	C++
 	mozilla.exe!main1(int argc=0x00000000, char * * argv=0x03e7a508, nsISupports * 
nativeApp=0x00000000)  Line 1336	C++
 	mozilla.exe!main(int argc=0x00000001, char * * argv=0x003f7c10)  Line 1827 + 0x16
	C++
 	mozilla.exe!mainCRTStartup()  Line 400 + 0x11	C
 	kernel32.dll!TermsrvAppInstallMode()  + 0x269	

running international browser buster

site: "http://www.sbs.co.kr/"
resource: "http://img.sbs.co.kr/newimg/200401/image/main_list_icon.gif"

Comment 1

13 years ago
*** Bug 266398 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

13 years ago
Summary: ###!!! ASSERTION: cache check failed: 'NS_SUCCEEDED(rv)', file r:/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 333 → ###!!! ASSERTION: cache check failed: 'NS_SUCCEEDED(rv)', file r:/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 333

Comment 2

12 years ago
Found this scanning top sites but could not reproduce when loading the pages
individually. It may be related to a relatively full cache. 

<http://www.imdb.com/rg/TRAIL_RH2/MIDDLE_RHS//title/tt0399201/trailers>
<http://www.msnbc.msn.com/id/3033063/>
(Reporter)

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5

Comment 3

12 years ago
I found out this seems to happen when a page load "times out" (it's not a real timeout as far as i know, the server accepts the TCP connection, but then does not send any HTTP commands or data in response to the GET /blabla and ends the connection with the normal FIN procedure like ~75 seconds later). If you then reload that page, you get the assertion.

Comment 4

12 years ago
-> default owner
Assignee: darin → nobody
Component: Networking: HTTP → Networking
QA Contact: networking.http → networking
overtaken by a decade of events.. and not actionable
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.