If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

scrolling within div with mousewheel does not work

RESOLVED DUPLICATE of bug 97283

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 97283
13 years ago
13 years ago

People

(Reporter: Mike de Munck, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

Scrolling with the mousewheel does not work within DIV's. The above link is a
perfect example. It does work properly in IE and Opera. The code of the page
(html + CSS) is according to W3C and contains (as far as I can see) no errors.

Reproducible: Always
Steps to Reproduce:
1. go to http://www.wilmaslapdance.nl/comics
2. Scroll with mousewheel
3.

Actual Results:  
The page doesn't scroll

Expected Results:  
The should scroll
(Reporter)

Comment 1

13 years ago
I would like to add that I have the latest version of Logitech Mouseware
installed (i don't know if this has anything to do with he problem though).

Comment 2

13 years ago
Created attachment 164153 [details]
Testcase with an absolutely positioned div

I'm not sure if this needs a testcase (or if a better one can be produced) but
this is something I'd prepared when I was about to submit this as a new bug.

Confirming with:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041028
Firefox/1.0RC1

In fact, the situation is slightly worse than the original poster suggests. If
you click within the top DIV of the attached, not only does the mousewheel not
work, but no navigation is available - UP/DOWN, PGUP/PGDN all fail, leaving no
way of viewing the offscreen content.

Comment 3

13 years ago
Isn't this the same bug as #97283?

*** This bug has been marked as a duplicate of 97283 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.