Context menu does not correctly display submenus on left when near right edge with frames

RESOLVED FIXED

Status

()

RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: will.dewitt, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

When right-clicking the context menu appears as normal.  Now move the mouse down
to This Frame (which should open a submenu).  Note that when the menu is opened
near the right-edge of the screen the submenu does not open on the left as it
should (oddly, this seems to work fine with IFRAMEs, such as the IFRAME hosted
on the guided Bugzilla bug entry script).

Reproducible: Always
Steps to Reproduce:
1. Right-click in a frame (not an IFRAME) near the right side of the screen.
2. Move the menu focus to the "This Frame" menu item.  This should invoke the
submenu.
Actual Results:  
The submenu opens to the right of the context menu, not to the left as it should.

Expected Results:  
The submenu should open to the left if the space on the right does not permit it
to fully display.

I have AdBlock and All-In-One Gestures installed, I recently uninstalled
TabBrowser Extensions (but have rebooted since then).
(Reporter)

Comment 1

14 years ago
Created attachment 163662 [details]
Test case HTML: fr.html opens fr1.html and fr2.html in frames
(Reporter)

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

14 years ago
Seems to be fixed in Firefox 1.0.  Marked it as Resolved/Fixed.
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.