Closed Bug 266416 Opened 17 years ago Closed 16 years ago

acrobat plugin obviously loads but does not display anything with mozilla 1.8a3 and 1.8a4

Categories

(Core :: Plug-ins, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 246560

People

(Reporter: jochen, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a4) Gecko/20041027
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a4) Gecko/20041027

Since mozilla 1.8a3 the acrobat plugin does not work anymore. When opening a pdf
file, the plugin loads (i.e. the adobe splash screen is shown), however nothing
is displayed, not even the acrobat reader controls, just an empty, white page.

there's no extra cpu activity or something strange, the browser is also still
working.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
For me it's the same. I can't remember that it ever worked with any 1.8 version.
Status: UNCONFIRMED → NEW
Ever confirmed: true
* Does acrobat work on its own? (i.e. can you save the PDF to disk, and then
view it with acrobat.

* Is this true for all PDFs? (I've seen this problem for cases where the PDF
file has newer features not supported by an older plugin )

* does it work if you de/re-install acrobat? 

* does it work if you install a newer version of acrobat?
1. acroread does work standalone without problems

2. every PDF I ever tried to open failed

3. reinstallation doesn't help 

4. I have tried 5.0.9 (latest) and 5.0.8
* Does acrobat work on its own? (i.e. can you save the PDF to disk, and then
view it with acrobat.
yes, perfectly

* Is this true for all PDFs? (I've seen this problem for cases where the PDF
file has newer features not supported by an older plugin )
yes, doesn't work for a single pdf

* does it work if you de/re-install acrobat? 
no, done this until my finger bleeded


* does it work if you install a newer version of acrobat?
tried three different versions, including latest, doesn't work on any
Do any messages appear in console when loading the plugin (assuming Mozilla is
started from there)? Also you might want to figure out when this regressed
exactly with the help of the builds from
http://archive.mozilla.org/pub/mozilla/nightly/ (Note: Mozilla 1.8a3 was
released around 2004-08-18, so test a few weeks before and so narrow down the
regression window).
when loading a pdf I get the following messages:

Warning: Actions not found: addBookmark, viewBookmark, copy, undefined-key,
find, findAgain, history, loadImages, openURL, mailNew, new, openFile, print,
exit, reload, saveAs, paste, delete, cut, undo, historyItem, back, forward,
abort, PageUp, PageDown
Warning: Actions not found: ManagerGadgetNextTabGroup,
ManagerGadgetPrevTabGroup, DrawingAreaInput, addBookmark, viewBookmark, copy,
undefined-key, find, findAgain, history, loadImages, openURL, mailNew, new,
openFile, print, exit, reload, saveAs, paste, delete, cut, undo, historyItem,
back, forward, abort, PageUp, PageDown
Warning: No action proc named "ManagerGadgetArm" is registered for widget
"form"
Document http://c0ffee.org/stuff/juhe-gmd.pdf loaded successfully

when clicking the part of the window, where the page should be displayed, i get
(per click):

Warning: No action proc named "ManagerGadgetArm" is registered for widget
"form"

the regression search will take a while...
maybe i'm sitting far to long in front of my pee cee today, but somehow most
directories in this archive are empty?

2004-08-05-12-trunk works fine

2004-08-05-23-trunk does not work

(could somebody remove the empty directories from archive.mozilla.org? it's
really a pain to find the few .tar.gzs in there...)
Thanks for testing! Here is the Bonsai link:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=SeaMonkeyAll&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2004-08-05+11%3A00%3A00&maxdate=2004-08-05+23%3A00%3A00&cvsroot=%2Fcvsroot
Now the question is, what checkin caused this. I don't see any highly suspicious
checkin there, maybe someone else can look into this...
i've just checked out the 2004-08-05 11:00 snapshot and will compile that now...
i'll try to apply every single patch then, so we'll see which one breaks it
Ok, I did the following to get the sources

cvs co mozilla/client.mk
cd mozilla
make -f client.mk MOZ_CO_DATE="2004-08-05 11:00" checkout

however, the patch produced by bonsai does not apply cleanly to this source
tree, and after compiling, the result mozilla can't display .pdfs correctly.

So I guess I'm doing something wrong there... could somebody help me, and
provide me with instructions on how to get the sources used to compiled
2004-08-05-12-trunk?
(In reply to comment #11)
> Ok, I did the following to get the sources
> 
> cvs co mozilla/client.mk
> cd mozilla
> make -f client.mk MOZ_CO_DATE="2004-08-05 11:00" checkout

I don't know if yours works, too but i would do this:
cvs -co -D "2004-08-05 11:00" mozilla/client.mk
cd mozilla
add 
mk_add_options MOZ_CO_DATE="2004-08-05 11:00"
to your .mozconfig.
make -f client.mk checkout
make -f client.mk build
Look if it works
cd ..
cvs update -j3.270 -j3.271 mozilla/layout/base/src/nsPresContext.cpp
(this is one checkin which could have caused this).
cd mozilla/layout/base/src
make
cd ../../build
make
Look if it works
report back :)
ok, I checked out & compiled mozilla as you've suggested, and... nothing,
doesn't work.

So I've downloaded 2004-08-05-12-trunk
(http://archive.mozilla.org/pub/mozilla/nightly/2004-08-05-12-trunk/mozilla-i686-pc-linux-gnu.tar.gz)
again and checked... works

strange enough, this 2004-08-05-12-trunk has build id 2004080510, however betwen
10 o'clock and 11 there were no checkins

I really wonder which sources were used to build this strange 2004-08-05-12-trunk
(In reply to comment #13)
> ok, I checked out & compiled mozilla as you've suggested, and... nothing,
> doesn't work.

Ok, so it doesn't work with and without the checkin into 
mozilla/layout/base/src/nsPresContext.cpp? To be honest, i don't understand this
then. Did you add ac_add_options --enable-default-toolkit=gtk2 and
ac_add_options --enable-xft to your .mozconfig (since the builds from -12 use
gtk2 and xft)? Maybe yours is a gtk(1) only bug?
(In reply to comment #14)

> Ok, so it doesn't work with and without the checkin into 
> mozilla/layout/base/src/nsPresContext.cpp?
I just checked whether it works _without_ the checkin (it doesn't)
 
> To be honest, i don't understand this
> then. Did you add ac_add_options --enable-default-toolkit=gtk2 and
> ac_add_options --enable-xft to your .mozconfig (since the builds from -12 use
> gtk2 and xft)? Maybe yours is a gtk(1) only bug?
I had gtk2 enabled, but not xft. I'm rebuilding with xft support now... will
report back in ~6h
(In reply to comment #15)
> I had gtk2 enabled, but not xft. I'm rebuilding with xft support now... will
> report back in ~6h

Sorry, forgot to tell you that :/, xft is now enabled by default when gtk2 is
enabled since a few month
btw, the official .mozconfig from the nightly builds looks like this:
export MOZILLA_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1
export BUILD_OFFICIAL=1
mk_add_options BUILD_OFFICIAL=1

ac_add_options --disable-tests
ac_add_options --enable-extensions=default,irc,tasks,negotiateauth
ac_add_options --without-system-nspr
ac_add_options --without-system-jpeg
ac_add_options --without-system-zlib
ac_add_options --without-system-png
ac_add_options --without-system-mng
ac_add_options --disable-debug
ac_add_options --enable-optimize="-O2 -gstabs+"
ac_add_options --enable-crypto

# GTK2+Xft
ac_add_options --enable-default-toolkit=gtk2
ac_add_options --enable-xft
MOZ_ENABLE_COREXFONTS=
ac_add_options --disable-freetype2
ac_add_options --disable-xprint
hi, compiled with xft enabled, still doesn't work.

I'll compile with the official mozconfig options now... cu in 6h
compiled again, doesn't work again.

i'll try two things now:

a) checkout a version from 2004-08-01

b) compile with gcc-3.3 instead of gcc-3.4

let's see which of those two will lead to success
still doesn't work :(

I'm running out of ideas what I could try next... any suggestions?
could it possibly be a subtle change in the tool-chain used to compile?

maybe all my builds won't work since i'm always using the same toolchain
aha :-)

mozilla-2004-08-05-12-trunk was compiled with gcc-3.2.3 
mozilla-2004-08-05-23-trunk was compiled with gcc-3.3.4

i'm compiling with gcc-3.4.2 and gcc-3.3.4

so I guess it's a problem with the abi changes between gcc-3.2 and gcc-3.3
*** Bug 272648 has been marked as a duplicate of this bug. ***
Blocks: 272648
I have exactly the same problem with Windows XP. I am currently using build
2005011204. The plugin worked with nightly builds back in November, I think.
Flags: blocking-aviary2.0?

*** This bug has been marked as a duplicate of 246560 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Flags: blocking-aviary2.0?
Resolution: --- → DUPLICATE
I wonder if this bug here still exists in this way, comet still says "Compiler
is -- gcc (gcc (GCC) 3.2.3". Maybe we just used the wrong builds from another
tinderbox to find the regression range...?
comet compiles gtk1 builds with gcc 3.2.3
lhasa compiles gtk2 builds with gcc 3.3.4

It is only gtk2 builds that are affected by the bug.
Jochen: are you sure your 2004-08-05-12-trunk build is gtk2
You need to log in before you can comment on or make changes to this bug.