If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Sort by Name does not sort items

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: Jonathan David Bloom, Assigned: Vladimir Vukicevic (BM, do not Cc or Request))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

Sort by Name doesn't work when I try to sort a bookmark by name.

Reproducible: Always
Steps to Reproduce:
1.Disorder bookmarks
2.Try to sort by name

Actual Results:  
This works in bookmark manager but then I can't change where the seperator is
and it has no effect on the actual bookmarks.

Expected Results:  
It should correctly sort by name.

Comment 1

13 years ago
Confirmed.

I have some content in some of my bookmark folders that were added after i
started using RC1. And the "sorting" option is not sorting the bookmarks into
these folders. And the Live Bookmarks folder moves its place and start appearing
as the last one on the Bookmarks toolbar folder. 
(Reporter)

Comment 2

13 years ago
RC2 does not fix this either.
The View->Sorted by Name doesn't actually sort the bookmarks, it allows you to
view them in a sorted manner.  Sort by Name in the bookmarks menu does work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

13 years ago
It doesn't work when right clicking the folder and pressing this. What shows up
in bookmarks manager does not show up in the actual bookmarks view.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(In reply to comment #4)
> It doesn't work when right clicking the folder and pressing this. What shows up
> in bookmarks manager does not show up in the actual bookmarks view.


What is "this"?  Your original report and this one are vague; please describe
exactly what items you're clicking on, what menu options you're selecting, etc.

Comment 6

13 years ago
Well, actually you CAN sort (or "view them in a sorted manner", whatever...)
bookmarks by name, but only if you choose "Manage Folder" and then use the
option "sort by name" into these folders.

Otherwise, it's not possible. And the Live Bookmark folders placed on the
bookmark toolbar folder continues to be sorted along with the other folders. In
the PR version the LB folders in the BTF did not changed its place when you
sorted a particular folder.
Assignee: vladimir → vladimir+bm

Comment 7

13 years ago
*** Bug 273231 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6)
Gecko/20041221 Firefox/1.0+.  I have to right-click on one of the items inside
the folder itself; doing so on the folder name of course sorts the folder's
siblings.
Invalid as per comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID

Comment 10

12 years ago
*** This bug has been confirmed by popular vote. ***
Ever confirmed: true

Comment 11

12 years ago
(In reply to comment #10)
> *** This bug has been confirmed by popular vote. ***
> 

I didn't click nor send the above. I was trying to vote on another bug, and this popped up on my screen. Are there issues with the bugzilla upgrade?
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.