Ctrl+Tab/Ctrl+Shift+Tab order should be ordered on a stack of most recently viewed, not a circular route around the order opened

RESOLVED DUPLICATE of bug 178556

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED DUPLICATE of bug 178556
14 years ago
14 years ago

People

(Reporter: Eric Medin, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

Like tab ordering in Windows, I expect to be taken to the last tab I had
selected before navigating to current tab.  So if I have more than 2 tabs open,
if I want to Ctrl+Tab between the first two, I should only have to do that once.
 Similarly, Ctrl+Shift+Tab should work from the bottom of that stack.

This should also address the problem of displaying the next tab over to the
right when closing the current tab _instead of_ displaying the tab viewed
previously to the current one that is being closed.

Reproducible: Always
Steps to Reproduce:
1. Open atleast 3 tabs
2. Select the "rightmost" tab
3. Select the "leftmost" tab
4. Hit Ctrl+Tab or close the "leftmost" tab 

Actual Results:  
The next tab over to the right of the "leftmost" tab (in this case the second
tab on the toolbar) is displayed.

Expected Results:  
The "rightmost" tab should have been displayed.

It's an easy fix; implement a stack, and every time a tab is given focus, move
it to the top of the stack.

*** This bug has been marked as a duplicate of 178556 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.