disabled toolbar button still fires onclick event

VERIFIED DUPLICATE of bug 7552

Status

()

P3
normal
VERIFIED DUPLICATE of bug 7552
19 years ago
19 years ago

People

(Reporter: bugzilla, Assigned: hyatt)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When a toolbar button is disabled using the attribute disabled="true", the 
button still fires an onclick event when you click on it!

You can see the problem in message compose window with the "Quote" or "Stop" 
button (starting in 02/05 build). Look at the output window. Same with the 
delete button in messenger 3Pane window.

I was expecting buttons will act like do menu items.

Comment 1

19 years ago
reassigning to evaughan for consideration in m15
Assignee: trudelle → evaughan
Target Milestone: M15

Comment 2

19 years ago
Hyatt,

I believe you know how to fix this.
Assignee: evaughan → hyatt
(Assignee)

Comment 3

19 years ago

*** This bug has been marked as a duplicate of 7552 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 4

19 years ago
veriifed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.