Firefox does not authenticate on ISA proxy server

RESOLVED EXPIRED

Status

()

Firefox
General
--
major
RESOLVED EXPIRED
14 years ago
13 years ago

People

(Reporter: eclipse, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

I am in a corporate network that uses Microsoft ISA server to access the
internet. This proxy requires NTLM authentication (domain username and
password). The domain is an Active Directory one.

The PC OS is NT4.0 workstation and the Firefox proxy settings are configured
properly.

Firefox 0.9.3 is working perfectly behind this proxy, while Firefox 1.0PR and
1.0RC1 fail to access outside pages with the following error:

"HTTP 407 Proxy Authentication Required - The ISA Server requires authorization
to fulfill the request. Access to the Web Proxy service is denied. (12209)
Internet Security and Acceleration Server"

Firefox 0.9.3 pops up a window to request the username and password needed to
authenticate on the proxy server, it carries on the auth correctly and then it
shows the requested web page.

Firefox 1.0PR (and also 1.0RC1) instead does not pop up any window for asking
the proxy authentication details and it shows directly the error page generated
by the proxy server.

Clearly something broke up in the transition from 0.9.3 to 1.0xx.


Reproducible: Always
Steps to Reproduce:
1.Install Firefox 1.0PR or 1.0RC1
2.Set proxy server settings to use internal LAN ISA server (proxy1:80)
3.Try to access whichever page on the internet


Actual Results:  
The browser cannot display any page outside the intranet or that requires NTLM
authentication. The browser fails authentication with ISA proxy server.


Expected Results:  
Negotiate correctly NTLM authentication as 0.9.3 did.
(Reporter)

Comment 1

14 years ago
I will upload 2 network stack traces: one generated with 1.0RC1 (not working)
and one generated with 0.9.3 (working).
Summary: Firefox does not authenticate on ISA server proxy → Firefox does not authenticate on ISA proxy server
Version: unspecified → 1.0 Branch
(Reporter)

Comment 2

14 years ago
Created attachment 163717 [details]
HTTP Log from Firefox 1.0RC1 when accessing ISA proxy server

Firefox 1.0RC1 cannot authenticate on ISA proxy server via NTLM
(Reporter)

Comment 3

14 years ago
Created attachment 163718 [details]
HTTP Log from Firefox 0.9.3 when accessing ISA proxy server

Firefox authenticates correctly with ISA proxy server via NTLM
(Reporter)

Comment 4

14 years ago
This issue looks like a blocking problem for all the users behind a corporate M$
proxy.
If you need further information, please let me know.
(Reporter)

Updated

14 years ago
Version: 1.0 Branch → unspecified

Comment 5

14 years ago
this seems to be no bug, but a change of configuration (about:config,
network.automatic-ntlm-auth.allow-proxies to be set to FALSE), see MozillaZine -
Firefox Bugs forum:
http://forums.mozillazine.org/viewtopic.php?t=143344
Whatever the reason for this change from FF0.9x to FF0.10x might be - the
default should be FALSE. THANKS to F@B :-)
(Reporter)

Comment 6

14 years ago
I checked on my machine the default configuration of
network.automatic-ntlm-auth.allow-proxies setting and it was set to TRUE.

I can confirm that changing network.automatic-ntlm-auth.allow-proxies to FALSE
solves the problem.

I don't know what should be the default and why it was changed.

I just hope that this information will be at least mentioned in the README of
the future 1.0 release.

Andreas, thanks for your help.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.