buglist.cgi can miss a <td>

VERIFIED DUPLICATE of bug 42041

Status

()

Bugzilla
Bugzilla-General
P3
minor
VERIFIED DUPLICATE of bug 42041
19 years ago
6 years ago

People

(Reporter: adam, Assigned: justdave)

Tracking

Details

(Whiteboard: 2.12)

(Reporter)

Description

19 years ago
sometimes when buglist.cgi is displaying its table, it leaves out a <td> for 
the platform field, which throws the whole row off (and probably breaks things 
in more anal browsers.) the reason for this is that rep_platform is declared as 
possible to be NULL, and if buglist.cgi gets a NULL it just skips the <td>. 
instead, it should insert a blank space. to fix this, change

if (!defined $value) {
  next;
}


to...


if (!defined $value) {
  $value = "&nbsp;";
}

Comment 1

19 years ago
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara

Comment 2

18 years ago
possible inclusion in 2.12
Assignee: tara → cyeh
Whiteboard: 2.12

Comment 3

18 years ago
i think this was fixed by this code:

                if (!defined $value) {
                    pnl "<TD>";
                    next;
                }
isn't that the equivilent?
I concur.  This bug report is much older than the one that it got fixed in.  
Since it did get fixed, and the other one actually has the patch that got used, 
making this a dupe.


*** This bug has been marked as a duplicate of 42041 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: Chris.Yeh → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: matty
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.