assertion (was crash) in AsyncReadStreamAdaptor

VERIFIED INVALID

Status

()

Core
Networking: Cache
P3
normal
VERIFIED INVALID
18 years ago
16 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: gordon)

Tracking

({crash})

Trunk
Future
x86
Other
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

I think it happens when my.netscape refreshes (automatically)

I checked in a fix to turn the crash into an assertion.

Index: cache/memcache/nsMemCacheChannel.cpp
===================================================================
RCS file: /cvsroot/mozilla/netwerk/cache/memcache/nsMemCacheChannel.cpp,v
retrieving revision 1.7
diff -r1.7 nsMemCacheChannel.cpp
122c122,128
<         rv = mDownstreamListener->OnStartRequest(mChannel, aContext);
---
>
>               NS_ASSERTION(mDownstreamListener, "no downstream listener");
>
>               if (mDownstreamListener) {
>                       rv = mDownstreamListener->OnStartRequest(mChannel, aCont
ext);
>               }
>
132,133c138,145
<               rv = mDownstreamListener->OnStopRequest(mChannel, aContext, stat
us, errorMsg);
<         mDownstreamListener = 0;
---
>
>
>               NS_ASSERTION(mDownstreamListener, "no downstream listener");
>
>               if (mDownstreamListener) {
>                       rv = mDownstreamListener->OnStopRequest(mChannel, aConte
xt, status, errorMsg);
>                   mDownstreamListener = 0;
>               }

here's the stack of the interesting threads:

NTDLL! 77f7629c()
nsDebug::Assertion(const char * 0x010086cc
??_C@_0BH@KIIE@no?5downstream?5listener?$AA@, const char * 0x010086e4
??_C@_0BE@LLJA@mDownstreamListener?$AA@, const char * 0x010086f8
??_C@_0EC@OKPH@D?3?2seamonkey?2mozilla?2netwerk?2cac@, int 140) line 189 + 13 bytes
AsyncReadStreamAdaptor::OnStopRequest(AsyncReadStreamAdaptor * const 0x02b7aad4,
nsIChannel * 0x02b7abd0, nsISupports * 0x00000000, unsigned int 2152398850,
const unsigned short * 0x00000000) line 140 + 41 bytes
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x02be3920) line 279
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x02be6770) line 93 + 12 bytes
PL_HandleEvent(PLEvent * 0x02be6770) line 526 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00cd44b0) line 487 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x04c6025c, unsigned int 49434, unsigned int 0,
long 13452464) line 975 + 9 bytes
USER32! 77e71820()
00cd44b0()


NTDLL! 77f6829b()
KERNEL32! 77f04f41()
_PR_WaitCondVar(PRThread * 0x00cd60c0, PRCondVar * 0x00cd62b0, PRLock *
0x00cd6360, unsigned int 4294967295) line 185 + 23 bytes
PR_Wait(PRMonitor * 0x00cd6410, unsigned int 4294967295) line 155 + 29 bytes
nsThreadPool::GetRequest() line 396 + 15 bytes
nsThreadPoolRunnable::Run(nsThreadPoolRunnable * const 0x00cd6270) line 591 + 11
bytes
nsThread::Main(void * 0x00cd6230) line 83 + 26 bytes
_PR_NativeRunThread(void * 0x00cd60c0) line 399 + 13 bytes
_threadstartex(void * 0x00cd7ed0) line 212 + 13 bytes
KERNEL32! 77f04ee8()


NTDLL! 77f6829b()
MSAFD! 77664a12()
WS2_32! 776b9f5e()
_PR_MD_PR_POLL(PRPollDesc * 0x00cd6e60, int 2, unsigned int 2125130) line 224 +
35 bytes
PR_Poll(PRPollDesc * 0x00cd6e60, int 2, unsigned int 2125130) line 115 + 17 bytes
nsSocketTransportService::Run(nsSocketTransportService * const 0x00cd50d4) line
429 + 24 bytes
nsThread::Main(void * 0x00cd6a20) line 83 + 26 bytes
_PR_NativeRunThread(void * 0x00cd68b0) line 399 + 13 bytes
_threadstartex(void * 0x00cd6700) line 212 + 13 bytes
KERNEL32! 77f04ee8()


USER32! 77e724b2()
nsDNSService::Run(nsDNSService * const 0x00cd7894) line 545 + 21 bytes
nsThread::Main(void * 0x00cd7850) line 83 + 26 bytes
_PR_NativeRunThread(void * 0x00cd76e0) line 399 + 13 bytes
_threadstartex(void * 0x00cd7530) line 212 + 13 bytes
KERNEL32! 77f04ee8()

Comment 1

18 years ago
reassign to gordon
Assignee: gordon@netscape.com → gordon

Comment 2

18 years ago
*** Bug 26704 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
Changing summary from: 
  crash (now assertion) when I have my.netscape.com and tinderbox up
to:
  crash (now assertion) in AsyncReadStreamAdaptor
Keywords: beta1, crash
Summary: crash (now assertion) when I have my.netscape.com and tinderbox up → crash (now assertion) in AsyncReadStreamAdaptor
Target Milestone: M14

Comment 4

18 years ago
Putting on PDT+ radar for beta1.
URL: [PDT+]

Comment 5

18 years ago
*** Bug 26640 has been marked as a duplicate of this bug. ***

Updated

18 years ago
URL: [PDT+]
Whiteboard: [PDT+]

Comment 6

18 years ago
I got this assertion viewing www.mp3.com (via the browser buster)

At first glance, my call stack looks slightly different to sspitzer's, hence my 
addition to this bug report..

Call stack:

NTDLL! 77f9f9df()
nsDebug::Assertion(const char * 0x019b9898 `string', const char * 0x019b98b0 
`string', const char * 0x019b98c4 `string', int 140) line 189 + 13 bytes
AsyncReadStreamAdaptor::OnStopRequest(AsyncReadStreamAdaptor * const 0x05759464, 
nsIChannel * 0x052f6c00, nsISupports * 0x00000000, unsigned int 2152398850, 
const unsigned short * 0x00000000) line 140 + 41 bytes
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x0524f8f0) line 
279
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x058f1ea0) line 93 + 12 bytes
PL_HandleEvent(PLEvent * 0x058f1ea0) line 526 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x02214580) line 487 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x000906a8, unsigned int 49435, unsigned int 0, 
long 35734912) line 975 + 9 bytes
USER32! 77e13eb0()
USER32! 77e1401a()
USER32! 77e192da()
nsAppShellService::Run(nsAppShellService * const 0x0220eec8) line 404
main1(int 1, char * * 0x00b26948, nsISplashScreen * 0x00000000) line 564 + 32 
bytes
main(int 1, char * * 0x00b26948) line 677 + 17 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e98b5b()
(Assignee)

Updated

18 years ago
Whiteboard: [PDT+] → [PDT+] 2/14/2000

Comment 7

18 years ago
This no longer crashes and is harmless. Erasing PDT+ for confirmation that 
this is non-beta1.
Whiteboard: [PDT+] 2/14/2000
Target Milestone: M14 → M15

Comment 8

18 years ago
reducing to minus based on warrens input.
Whiteboard: [PDT-]
(Assignee)

Updated

18 years ago
Target Milestone: M15 → M17
(Assignee)

Updated

18 years ago
Keywords: beta1, crash

Comment 9

18 years ago
Moving post beta bugs to M18 which is now the post-beta milestone.
Target Milestone: M17 → M18

Comment 10

18 years ago
Adding crash keyword.
Keywords: crash

Comment 11

18 years ago
I'm wondering if bug 41462 is a dup of this one. Anyone could verify?
Bug 41462 has been resolved as duplicate of bug 40116.

Comment 13

18 years ago
It seems like this was a temporary fix. We need to investigate its current 
situation. 
Keywords: crash
Summary: crash (now assertion) in AsyncReadStreamAdaptor → assertion (was crash) in AsyncReadStreamAdaptor
Whiteboard: [PDT-]

Comment 14

18 years ago
Adding crash keyword to all open crash bugs that don't already have it...
Keywords: crash
(Assignee)

Updated

18 years ago
Target Milestone: M18 → Future
(Assignee)

Comment 15

17 years ago
This is an old cache bug.  It will no longer apply when IMAP finishes it's 
transition to the new cache.  Marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 16

16 years ago
re-opening to mark INVALID
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 17

16 years ago
INVALID per gordons comments
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → INVALID

Comment 18

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.