<a> tag not closing after trailing slash (ie. <a />)

RESOLVED INVALID

Status

()

Firefox
General
--
trivial
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Speedy Phoenix, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Opera/7.54 (Windows NT 5.1; U)  [en]
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)

The page at http://www.eugenechoi.com/, in the beginning of every "blog" entry, 
the anchor tag (ie. <a id="_23" />) extends to the next hyperlink. According to 
w3 specifications, the trailing slash should close the tag, and therefore the 
anchor should not extend to the next hyperlink. The site validates completely as 
xhtml transitional.

Reproducible: Always
Steps to Reproduce:
1. Visit the site.
Actual Results:  
anchor tag extends to next hyperlink

Expected Results:  
anchor tag extends to next hyperlink

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

13 years ago
You can't use XML syntax unless the site is served as application/xhtml+xml. 
Since this page is served as text/html, it is parsed as HTML.  So the code must
follow the Appendix C compatibility rules in the XHTML spec.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.