Last Comment Bug 266511 - Import Wizard doesn't show what items were imported
: Import Wizard doesn't show what items were imported
Status: RESOLVED FIXED
: fixed-aviary1.0, regression
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: unspecified
: x86 Windows 98
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 267899 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-28 12:09 PDT by Alex Eng
Modified: 2012-04-25 08:45 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screen shot of Import Wizard (from 2004-10-04 branch build) (3.63 KB, image/png)
2004-10-28 12:11 PDT, Alex Eng
no flags Details
Screen shot of Import Wizard (from 2004-10-14 branch build) (3.12 KB, image/png)
2004-10-28 12:12 PDT, Alex Eng
no flags Details
patch (1.32 KB, patch)
2004-11-04 11:17 PST, Ben Goodger (use ben at mozilla dot org for email)
no flags Details | Diff | Splinter Review

Description Alex Eng 2004-10-28 12:09:47 PDT
The Import Wizard that appears when starting Firefox for the first time doesn't
display what items (bookmarks, cookies, browsing history, etc.) are being
imported (2nd screen of wizard), nor does it display the items that were
successfully imported (3rd screen of wizard).

This seems to have regressed between the 2004-10-05 and the 2004-10-14 branch
builds.
Comment 1 Alex Eng 2004-10-28 12:11:08 PDT
Created attachment 163733 [details]
Screen shot of Import Wizard (from 2004-10-04 branch build)
Comment 2 Alex Eng 2004-10-28 12:12:33 PDT
Created attachment 163734 [details]
Screen shot of Import Wizard (from 2004-10-14 branch build)
Comment 3 Alex Eng 2004-10-28 12:21:46 PDT
This problem occurs regardless of which browser to import data and settings from
(IE, Mozilla 1.x or Netscape 6/7, Netscape 4.x).

However, the Import Wizard works as expected when invoking it from File | Import.
Comment 4 Ben Goodger (use ben at mozilla dot org for email) 2004-11-04 11:17:10 PST
Created attachment 164612 [details] [diff] [review]
patch
Comment 5 Dimitrios 2004-11-05 04:57:49 PST
*** Bug 267899 has been marked as a duplicate of this bug. ***
Comment 6 Alex Eng 2004-11-05 19:13:16 PST
Verified fixed on the 2004-11-05 branch build (build ID: 2004110506)
Comment 7 Alex Eng 2005-01-02 22:39:29 PST
Reopening.  When starting Firefox for the first time, Import Wizard doesn't show
what's being imported (wizard screen 2).  But it does show what was successfully
imported (wizard screen 3).

As in comment #3, this doesn't occur when invoking from File | Import from main
browser window or Bookmarks Manager.

Reproduced on 2005-01-02 trunk build.
Comment 8 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-04-25 08:45:26 PDT
It's ver bad ui ("migrating" items are bold briefly), but there are quite a few bugs filed just for that. The issue reported in this bug was fixed long ago.

Closing.

Note You need to log in before you can comment on or make changes to this bug.