File -> Exit doesn't work

RESOLVED INVALID

Status

()

Firefox
Menus
--
minor
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: gil, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

The "Exit" option in the "File" menu does nothing, while closing with the "X" in
the top-right corner does close firefox.

Reproducible: Always
Steps to Reproduce:
1. Open firefox
2. Try to close if with the Exit option in the File menu


Actual Results:  
Nothing happens

Expected Results:  
Firefox exits

Comment 1

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103
Firefox/1.0RC2
Windows XP.
Same bug.

Comment 2

14 years ago
It, however, warns the user if he has more than one tab opened. Upon selecting
the option to close all tabs, nothing happens. Subsequent clicks to File>Exit
command do nothing.

So, confirming on "Mozilla/5.0 (Windows; U; Windows NT 5.1; sl-SI; rv:1.7.5)
Gecko/20041108 Firefox/1.0" (yes, official 1.0 build!).
Slovenian version on Windows XP, as you can see from the string.

Comment 3

14 years ago
*** Bug 266670 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
gil,
As the person who originally registered the bug, you have permissions
to change the status:
This effects "all" platforms (Linux, MacOS, Windows) across several
versions of each. - If my attempt fails to change that status to "all".
Also, as it's a pretty "in your face" item that many users may experience
I'd also reccomend upgrading from "minor" to "normal"
Lastly, it would be the 1.0 branch -- problem cropped up in ff-1.0-rc1
(that was after ff-1.0PR and includes ff-1.0 final (nov 9))
Thanks

Comment 5

14 years ago
This bug happens for me as well.
WinXP Pro SP2
upgrade from Firefox1.0PR -> Firefox1.0
I did not uninstall 1.0PR prior to installing 1.0
I had the Smoke theme from Aaron Spuler installed on 1.0PR, upgrade disabled
theme when starting 1.0 version.
Problem occured from the first time 1.0 was started and still affects it, even
after installing the updated version of Aaron's Smoke theme.
(Reporter)

Updated

14 years ago
OS: Windows 98 → All

Comment 6

14 years ago
Did some more digging and found that my occurance of this bug is caused by the
extension "Download Statusbar" by Devon Jensen. Unistalling the extension
corrects the problem for me. 100% reproducible.
I believe that the Download Statusbar extension registers a custom function in
place of window.goQuitApplication
I'm not sure how to fix this as I'm not familiar with writing extensions for
Firefox, so I'll leave it for someone else.
So for me, this bug does not affect my system: Mozilla/5.0 (Windows; U; Windows
NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Comment 7

14 years ago
(In reply to comment #6)
> Did some more digging and found that my occurance of this bug is caused by the
> extension "Download Statusbar" by Devon Jensen. Unistalling the extension
> corrects the problem for me. 100% reproducible.
> I believe that the Download Statusbar extension registers a custom function in
> place of window.goQuitApplication
> I'm not sure how to fix this as I'm not familiar with writing extensions for
> Firefox, so I'll leave it for someone else.
> So for me, this bug does not affect my system: Mozilla/5.0 (Windows; U; Windows
> NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Confirm that. I have disabled extension "Download Statusbar" and firefox exited
when I clicked File - Exit.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Comment 8

14 years ago
Open two Firefox windows.  Make the first one have multiple tabs open, so it
will notify you before it closes.  On the second, most recently opened winodw,
click File>Exit.  It will try to close the first window....go figure!

Comment 9

14 years ago
Since at least two people have confirmed that this is/was an extension bug I'm
closing as INVALID. If anyone is still seeing this without extensions then
please reopen.

p.s. Kyle that is by design, "File->Close Window" closes the current window,
"File->Exit" closes all windows.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

12 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.