Password Manager is too agressive. It shouldn't replace text in fields where values are set.

RESOLVED DUPLICATE of bug 259841

Status

()

Toolkit
Password Manager
RESOLVED DUPLICATE of bug 259841
14 years ago
10 years ago

People

(Reporter: Vasya Pupkin, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

After Firefox 0.9.3 all versions of Firefox have this bug with password manager.
It replaces data in forms where it shouldn't. For example, I have a phpBB
powered forum, I used Password Manager to remember my password to forum. It's
ok. But when I try to edit some user via Admin Control Panel, Password Manager
REPLACES username and user's password to MY NAME AND MY PASSWORD! It shouldn't
do that. It should fill my username and password only in that form, where I have
remembered it, not in all places of the website. And not in that forms, where
fields have a value set. The best thing is if Password Manager will not fill
forms automatically AT ALL, like in Opera, for example.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
Duping to similar problem in Bug 259841.  Reporter, if you feel this was done in
error please REOPEN.

*** This bug has been marked as a duplicate of 259841 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.