Mozilla does not open to URL in a Shortcut or from an external application

RESOLVED DUPLICATE of bug 267313

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 267313
13 years ago
6 years ago

People

(Reporter: Alan Smedley, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041028
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041028

I have a few Favourite URLs saved as shortcuts.  For about a week in the nightly
builds of Mozilla these have no longer worked.  Also from an external URL
reference or a program that is a web search engine I am unable to go to the
found URLs.  Mozilla opens but goes to the default page only.

I have completely uninstalled Mozilla and reinstalled from version 1.7.3 then
the current nightly build to confirm this.

I have also cleared all of my Temp directories and Caches without a satisfactory
result.

Reproducible: Always
Steps to Reproduce:
1. From a previously working Web Shortcut attempt to go to it. 
2.
3.

Actual Results:  
Mozilla opens the default Home Page.

Expected Results:  
Mozilla should open the URL

Comment 1

13 years ago
Looks similiar to 266512. Duplicate?
Alan, can you narrow down exactly when this broke?
(Reporter)

Comment 3

13 years ago
To get this running satisfactorily again I am going back to 2004102505 after
testing each new nightly build.
So it's broken in the October 26 morning builds?  If you can tell me when this
broke, I may be able to find the chekin that was responsible.
(Reporter)

Comment 5

13 years ago
Thats correct. Anything after 2004102505 fails for me.
(Reporter)

Comment 7

13 years ago
With todays build (2004110104) the error loading Mozilla from a saved shortcut
URL only ocurrs if an instance of Mozilla is already open on the screen.  A new
window of Mozilla is opened to the default page and not the saved shortcut URL.

Comment 8

13 years ago
*** Bug 267232 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
I can't reproduce this with mozilla trunk. I would naturally suspect my
app-startup checkins, unless this happened before that.

Comment 10

13 years ago
(In reply to comment #7)
> With todays build (2004110104) the error loading Mozilla from a saved shortcut
> URL only ocurrs if an instance of Mozilla is already open on the screen.  A new
> window of Mozilla is opened to the default page and not the saved shortcut URL.

Bug 267313 looks very similiar to that.
Reporter, are there any errors in the JS console?
(Reporter)

Comment 12

13 years ago
Sorry but what is the JS console??
Tools/web Development/Javascript Console
(Reporter)

Comment 14

13 years ago
I have the following ( so I will try and reinstall sthe Sun Java) These were
when I had my homepage opened to http://telstra.com/

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIControllers.removeController]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://navigator/content/navigator.js :: Shutdown :: line 750"  data: no]

Error: Selector expected.  Ruleset ignored due to bad selector.
Source File: http://telstra.com/global/css/gwy_hed.css
Line: 13

Error: Unexpected end of file while searching for 'closing } of invalid rule set'.
Source File: http://telstra.com/global/css/gwy_hed.css
Line: 13
(Reporter)

Comment 15

13 years ago
Ri-Installing of Sun Java jre-1_5_0-windows-i586.exe said that it was already there.
Note:Javascript is NOT Java and Java has nothing to do with this..
Flags: blocking1.8a5?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 17

13 years ago
CTho, did you actually reproduce this? Steps to reproduce, please?
I can reproduce this, bsmedberg.  Incoming ICQ links don't work when passed to
Mozilla, nor do X-Chat (for windows) links.  All they do is open a new window
(with whatever settings you have; in my case that's to open the homepage).
Yes, what stephend said.  I think bug 267313 is really a dupe of this bug rather
than a dependency.
This works in my self-compiled Mozilla from yesterday on win2k and Xchat.
Could be an installer/package issue (missing/wrong registry-keys) ?

Comment 21

13 years ago
I think this must be some sort of installer issue. I cannot reproduce this with
downloaded Windows ZIP builds, I will try the installer shortly.
Changing my DDE message from "%1",,-1,0,,,, to "%1" solved the issue for me.
(Reporter)

Comment 23

13 years ago
I have worked out further info on this Bug.  If I download and install the
latest version from
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-1.7/ which is
dated 03-Nov-2004 15:18 the error I am still seeing on the Latest Nightly Builds
(currently 2004110505) does not happen.  So I am guessing it is an error in the
way that the Nightly Builds are packaged compared to the way that the ones in
the latest-1.7 directory are packaged. 
That means only that the old 1.7 branch is different
(Reporter)

Comment 25

13 years ago
> That means only that the old 1.7 branch is different

If it is not showing the error in that branch then it is correct whereas the
Latest directory branch has an error.  Or is the version in the 1.7 branch much
older than the date implies?
Alan, most of the 1.7 branch is seven months old.  Security and crash fixes have
been going into the branch, but primary development has been taking place on the
trunk.
(Reporter)

Comment 27

13 years ago
I am using the build 2004110606 today and have isolated the fault some more to
shortcuts that are in the form of http:// as different from https://  So with
shortcut to a "Secure" http site Mozilla works fine but to an "Unsecure" http
site Mozilla fails , and just opens another Default page.  (Also I am not sure
if its related but in all this Mozilla is opening a new Window, not changing the
page in the existing open Mozilla Window)  
Windows uses separate settings for http vs. https URLs.
(Reporter)

Comment 29

13 years ago
So aryou say that the error is in Mozilla's handling of these two different URL
types? Or is it a Windows OS error?
See comment 22 - something that used to work stopped working - I expect it's a
change in Mozilla's behavior somewhere, rather than Windows.

If you go open windows explorer, choose Tools->Folder Options, File Types,
scroll down to "(NONE) URL:Hyper Text Transfer Protocol", click Advanced, select
open, click Edit, and compare the settings there to the settings for HTTPS, I
expect something will be different.
(Reporter)

Comment 31

13 years ago
Is there a way to track progress on the resolution of this problem.  I am still
checking each new nightly build but having to revert to the version 2004102505
as each new build still fails for me.
All progress on the bug should be noted in the form of added comments and/or
attached patches.  Until the status is changed to "resolved fixed", the bug is
not fixed.

Updated

13 years ago
Flags: blocking1.8a5? → blocking1.8a5+

Comment 33

13 years ago
*** Bug 267110 has been marked as a duplicate of this bug. ***

Comment 34

13 years ago
I had a bug that was a duplicate to this one and somebody said that builds up to
the 30th were not displaying the problem since i see on this discussion that the
problem started on the 26th I think that we should check this again. See bug 267110
(Reporter)

Comment 35

13 years ago
I have just tried this out again with the nightly build for the 29th and confirm
that the error is definately present in it.  As I recollect I have already
stepped back through the versions untill I found that the one for the 25th did
not have a problem with this bug.  I will work back more as I have time unless
someone else wants to confirm this again before I do. 
(Reporter)

Comment 36

13 years ago
I have just noticed that this problem of Mozella only opening to the default
page also will happen if any componant of Mozilla appart from the QuickStartUp
is open.  I have had just the Download Manager open (No Mozilla Browser Windows
open) and trying to open to a saved URL opens up only to the selected Default
page in Mozilla.

To further test I have also download and tested with a Stub Install as well as
the complete download install. Both of these currently fail
Severity: normal → major
To reproduce this, are you attempting to load the external link with Mozilla
already running?  
also..
Is the external link loaded properly if Mozilla has to be launched by the system
call from the external link.  If so, bug 266313 is a dupe of this.

Comment 38

13 years ago
(In reply to comment #37)
> ... If so, bug 266313 is a dupe of this.
You mean bug 267313.
Likely, but not proven yet, is that Darin's changes for bug 262218 may have
caused/exposed this.

Comment 40

13 years ago
Darin, can you look at this? 

Comment 41

13 years ago
Yes, I'm updating my windows tree at the moment...
I tried to reproduce with v1.8a4 and v1.8a5 (with an http url shortcut, on W98SE):
I saw the bug ... then couldn't reproduce :-/

Detailed steps needed !
Keywords: regression

Comment 43

13 years ago
Patch from bug 267313 should fix this.

*** This bug has been marked as a duplicate of 267313 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Flags: blocking1.8a5+
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.