If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

PopUps shouldn't open as new tabs, they should open as new windows instead.

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Vasya Pupkin, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

In 1.0RC1 there's options regarding tabbed browsing. These options replaces
SingleWindow plugin functionality. I'm using option "Force links that opens in
new window to open in NEW TABS". This option is forcing PopUps to open as tabs,
but this is incorrect. PopUps should remain popups, I can't work with some sites
due to this behaviour. The good-old SingleWindow plugin worked perfectly for me.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

13 years ago
Also, this option ignores setting to open new tabs in background.

Comment 2

13 years ago
If you were to have this feature, it would need to be user-selectable I think
because one of the main attractiveness points with Firefox is that you can
browse completely using one window using tabs. To break this pattern could open
Firefox up to the same problems as occur frequently in IE where seemingly
unlimited popups can be opened by certain unscrupulous websites.

Comment 3

13 years ago
There is a pref for that. In future please search and use support forums first.
http://www.mozilla.org/support/firefox/tips#beh_newwindows
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.