If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

New installer options - default browser and profile migration

RESOLVED WONTFIX

Status

()

Firefox
Installer
--
enhancement
RESOLVED WONTFIX
13 years ago
11 years ago

People

(Reporter: Jared, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

I'd like to suggest adding two options to the Firefox installer - whether or not
to set the default browser, and whether or not to run the profile migration wizard.

Firefox currently prompts the user (in Windows) to set it as the default browser
upon initial launch, but it would be nice to have that option during the actual
install.  This would be especially useful for silent installs, deployments, etc.

The other request is similar - include an option in the installer to enable or
disable the profile migration wizard upon initial launch.  This would also be
useful for silent installs and deployments, where it otherwise might confuse or
annoy the user (I fall into the latter category :-).

Thanks.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Updated

12 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → installer
Current releases of Firefox support -silent -setDefaultBrowser arguments for setting the default browser. I doubt that it would get ui in the installer since it will prompt on first app run to set as the default browser.

I am unsure if the app supports an argument to not migrate and the app would need to support it first.
For setting the default browser you can launch the app after the installation with the -silent -setDefaultBrowser command line arguments. Also see http://wiki.mozilla.org/Installer:Command_Line_Arguments for draft installer documentation on administrative installs.

To support migration from the installer the app will need to first implement this. If you believe the app still needs to support this please file a bug for it under Firefox ->  Migration since that is where the majority of the work will need to be done first and the installer work to support this is minimal.

Since there is a method to accomplish setting the default browser which is part one of this bug resolving -> wontfix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.