Cannot switch to default theme when in safe mode

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: syskin2, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

If your current theme is broken, you cannot start FF in normal mode but can
start it in safe mode, which is designed to let you recover from such problem.
However, you cannot change, uninstall or otherwise disable a broken theme.

Reproducible: Always
Steps to Reproduce:
[abstract way]
1. Imagine that your non-default theme is broken and you cannot start firefox
2. Start in safe mode. Browser starts with default theme, so use theme manager
to disable or unistall the offending theme, or otherwise recover from the problem

[real-life way]
1. backup your profile ;)
2. install Pinball 0.9.9.1 from u.m.o
3. observe that you are in *big* trouble
4. start in safe mode. Browser works, so use theme manager to disable or
unistall pinball, or otherwise recover from the problem
Actual Results:  
In safe mode, it is not possible to switch themes or unistall offending theme

Expected Results:  
You can switch to default theme. In fact, how about being able to switch to
*any* theme, it's just a configuration change anyway.

Updated

14 years ago
Severity: normal → major

Comment 1

14 years ago
In safe mode, you should launch in the default theme and should not be able to
switch to other themes. That's the point of safe mode, where themes are
concerned.  I was able to uninstall other themes in safemode. note: selecting
the theme to be deleted doesn't highlight it; just click it then click uninstall.

marking wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 2

14 years ago
Doesn't WFM 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050418
Firefox/1.0.3 (MOOX M3)
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

14 years ago
More specifically, I can't switch to the default theme, because even THAT one is
disabled.

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is WFM since the patch for bug 293548 was checked in. I also tested by
selecting a theme other than the default theme, restarting, restarting in safe
mode, selecting use theme for the default theme, and restarted again with the
result of the default theme being the one used.

Resolving WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.