account identity copies to wrong sent items folder

VERIFIED DUPLICATE of bug 262300

Status

Thunderbird
Message Compose Window
VERIFIED DUPLICATE of bug 262300
13 years ago
13 years ago

People

(Reporter: Simon Tuckwell, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

Under my IMAP account, I have changed my sent items folder from the default to
me@mydomain.com->"Sent Items".  I have set up several identities, such as
abuse@mydomain.com.  If I send mail using an identity the e-mail is copied into
me@domain.com->"Sent" instead of my selected folder.  The correct folder is used
if I don't change the identity.

Once the "Sent" folder is created it cannot be deleted within Thunderbird.


Reproducible: Always
Steps to Reproduce:
1.Change Sent Items folder in account settings.
2.Add an identity.
3.Send mail using identity.

Actual Results:  
Copy of sent item found in "Sent" folder.

Expected Results:  
Copied message to "Sent Items" folder.

Using Thunderbird 0.8+/0.9 20041027.

Comment 1

13 years ago
Copying to the Sent folder is controlled by the identity-specific fcc and 
fcc_folder preferences:
  mail.identity.idXXX.fcc
  mail.identity.idXXX.fcc_folder

If you make a change to the default identity, these settings are not propogated 
to the other identities -- which is sensible if you've set up to use specific 
folders for specific identities, but otherwise is a pain.  You can edit the 
settings manually in prefs.js.  The duplicate bug requests a UI for all the 
identity-specific preferences.

*** This bug has been marked as a duplicate of 262300 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.