When pasting "large" list of addresses into composer or mailing list fields, Thunderbird crashes

RESOLVED WORKSFORME

Status

Thunderbird
General
--
critical
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Paul Kopacz, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040927
Build Identifier: version 0.8 (20040913)

I have people in the office who get large files with, for example, student
emails that they have to send an email to.  These are text files with one email
address per line.  They are used to (using Pegasus Mail) just copy and pasting
these addresses into a Bcc field of an email.  I tried to do the same thing in
Thunderbird.  This works for small numbers of addresses (I do not know what the
"upper limit" is, although I did do 40 successfully).  But we are talking
hundreds of emails at a time, and this crashed Thunderbird (but not Pegasus). 
We are moving to a server side solution to this anyway, but just thought someone
might be interested in (what appears to be) an uncaught error.

Reproducible: Always
Steps to Reproduce:
1.Select large number of email addressess 
2.Ctrl-V or middle click selection into the To field of a new message or the To
field of a new list in the contacts manager.


Actual Results:  
Thunderbird crashes

Expected Results:  
Either informed me that there was an upper limit on the number of addresses that
can be pasted, or sucked it up and took it :)

Comment 1

14 years ago
Could you provide Talkback IDs for the crashes?
(Reporter)

Comment 2

14 years ago
I cannot, as Talkback does not seem to start when the crash happens.

I get this upon crash if I run it command-line:

./run-mozilla.sh: line 451: 26498 Segmentation fault      "$prog" ${1+"$@"}

Comment 3

13 years ago
i tried the same with 196 addresses and Mozilla Thunderbird Version 1.0.2
(20050317) crashed with the following error message:

--
Fehler beim Senden der Nachricht. Der Mail-Server antwortete: sorry, no mailbox
here by that name (#5.1.1 - chkusr). Bitte überprüfen Sie, ob Ihre
E-Mail-Adressen in den Konten-Einstellungen stimmt und wiederholen Sie den Vorgang.
--

in english
--
Error while sending a message. Answer of the mail-server: sorry, no mailbox here
by that name (#5.1.1 - chkusr). Please check your email-addresses and try it again.
--

If i seperate these 196 addresses in smaller pieces it works fine.

Comment 4

13 years ago
(In reply to comment #3)
> i tried the same with 196 addresses and Mozilla Thunderbird Version 1.0.2
> (20050317) crashed with the following error message:

solved... sorry for the spam
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 6

13 years ago
This is still present in the 1.0.6 release.  There is some upper limit to how
much text can be put into the To/CC/Bcc field of the compose new message window.
 If that limit is crossed, it will die with the following message:
/opt/thunderbird/run-mozilla.sh: line 451: 12477 Segmentation fault      "$prog"
${1+"$@"}
Where the 12477 varies every time I do a test: 12213, 12246, 12275, 12312,
12370, 12402, 12436, 12477, 12519, 12574, 12606 all came up (in that order)
during my testing.  The limit seems to be something like 4100 characters,
althought this isn't consistent.  For example, if I paste 4120 it will crash,
but if I paste 4110  and proceed to type more characters, I will be able to type
more than another 10 characters before it crashes.  If you need any more
information about my system, please let me know.

Comment 7

13 years ago
reporter: please try 1.5 candidates or trunk
(Reporter)

Comment 8

12 years ago
(In reply to comment #7)
> reporter: please try 1.5 candidates or trunk
> 

Fixed as of Thunderbird 1.5!
It allows me to either paste in a large number of addresses, or refuses to paste if the list is too long, both being the right thing to do.  When pasting in (I tried with about 6000 addresses) there is a weird display artifact happening; it appears as if text is "on top of" other text, leading to a blur within the field.  I don't know if someone wants to bother to confirm that, it's not really a problem for me.  Thanks for all the hard work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.