If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Resizing window causes incorrect reflow.

VERIFIED WORKSFORME

Status

()

Core
Layout
P3
normal
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Michael Bedy, Assigned: Kevin McCluskey (gone))

Tracking

({verifyme})

Trunk
x86
Linux
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I'm surprised that I couldn't find an exisiting bug for this one. I probably
just missed it.

Anyway, if you resize the window while viewing www.mozilla.org, the tables do
not resize correctly, and instead leave a blank area between the link list on
the left, and the middle area box (with the news in it.)

Comment 1

18 years ago
Works fine for me on NT with latest build. Re-assigning to Kevin to see if the 
problem is Linux specific (we seem to have a lot of Linux specific problems 
lately)
Assignee: troy → kmcclusk
(Reporter)

Comment 2

18 years ago
Ah ha! Far more tricky than I thought it was...

This bug is only triggered when the page incrementally reflows a couple of times
during page load. That's why hitting reload fixed it. When I turned off the
memory cache, forceing it to pull the page through the modem again, and hit
reload, the bug reappeared. Also, now that I look at it, the page renders
incorrectly to begin with. (The window resize just makes it look worse)
It renders correctly if it only lays-out once (as it does when it is in the
cache.)

I think you'll have to have a low speed connection to see it happen. For the
record, I see it reflow three times while it loads.

CCign back to troy@netscape.com, since this information might be useful.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M15
(Assignee)

Comment 3

18 years ago
Tried with todays build and I was not able to reproduce the problem. This bug 
was probably fixed along with some general update issues on Linux. Marking as 
worksforme.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Updated

18 years ago
Keywords: verifyme

Comment 4

18 years ago
Resizes beautifully on Linux in build 2000060508
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.