Right-click context menu shows incorrect "about" item

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
--
trivial
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: Christopher Curzio, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

When right-clicking an extension when a different extension is selected, the
"About" item in the context menu displays the last selected extension. 

Reproducible: Always
Steps to Reproduce:
1. Open the extensions manager. 
2. Left-click an extension to select it. 
3. Immediately right-click a different extension.

Actual Results:  
The 3rd item in the context menu will display as "About (previous extension)"
Clicking the item behaves properly. 

Expected Results:  
Properly display the correct "About" item.

Comment 1

13 years ago
You've got to be quick to move to another extension, but confirmed on WinXP.
Downgrading severity.
Severity: normal → trivial
OS: Linux → All
(Reporter)

Comment 2

13 years ago
Speed doesn't seem to be a factor on Linux. You can wait 2 seconds or 5 minutes
before right-clicking on a different extension, with the same results. 
This is a duplicate of #260684.

Both are due to the fact that the function in onpopupshow is called before the
selection in the vbox is changed by the right click event.

Comment 4

13 years ago
*** Bug 275081 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
fwiw, I cannot reproduce this on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.7.5) Gecko/20041107 Firefox/1.0. This is either a Linux only or a different
bug.

The (different) bug that I can reproduce is: (1) select an item, (2) hold right
button (while hovering the other item) and move it slightly, (3) release right
mouse button. The selection is not changed, and the "wrong" title is shown in
the right-click menu. So the problem with me is that firefox changes selection
in onmouseup/click, not in onmousedown.
Blocks: 260684
*** Bug 271660 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
OS: All → Linux

Comment 7

13 years ago
Samir, what build did you test this with?

Comment 8

13 years ago
Tested with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050403
Firefox/1.0.3

I cant reproduce it...

Comment 9

13 years ago
Well, since this was reported on a Linux build, it should be tested on Linux
before being resolved as WFM, reopening.

Christopher (or anyone else), can you still reproduce this? If not, please
re-resolve as WFM.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 10

13 years ago
I can confirm this behaviour

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050405 Firefox/1.0+

Comment 11

13 years ago
This also happens to me.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Additionally, I see the following behavior:

1. Left-click an enabled extension.
2. Right-click the same extension.
3. Choose Disable on the context menu.
4. Immediately right-click another enabled extension.

Actual behavior: The "enable/disable" option on the menu incorrectly shows
"Enable" and is disabled (grayed-out).
Expected behavior: The menu item should be "Disable" and should be selectable.

This can be annoying when having to enabling/disabling several extensions.

Comment 12

13 years ago
I can reproduce this problem on:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050505 Firefox/1.0+
Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7.7) Gecko/20050421 Firefox/1.0.3
(Debian package 1.0.3-2)
The selection code has been rewritten with the landing of bug 285584. Can this
still be reproduced?

Comment 14

13 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050819
Firefox/1.0+.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME

Comment 15

13 years ago
*Sigh*
This is a Linux-only bug and should be tested on Linux.

However the EM UI rewrite indeed fixed the bug here:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050813 Firefox/1.0+
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.