Crash in nsSocketTransport::doRead() while browsing GIMP's gallery...

RESOLVED FIXED

Status

()

P3
blocker
RESOLVED FIXED
19 years ago
16 years ago

People

(Reporter: roland.mainz, Assigned: rpotts)

Tracking

({crash})

Trunk
Sun
Solaris
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

19 years ago
"bus error" in socket support code with browsing with my own Solaris 2.7/MU4
SPARC M13 build.

Zilla's last words were:
-- snip --
Document http://www.gimp.org/ loaded successfully
Document: Done (4.66 secs)
JavaScript Error: TypeError: controller has no properties

title string = [The GIMP Homepage - Mozilla]
Document http://www.gimp.org/the_gimp_screenshots.html loaded successfully
Document: Done (2.307 secs)
Going Back
Error loading URL http://www.gimp.org/icons/gimp_in_action1.jpeg 
Document: Done (16.558 secs)
title string = [The GIMP Homepage - Mozilla]
Document http://www.gimp.org/the_gimp_screenshots.html loaded successfully
Document: Done (3.707 secs)
Bus Error - core dumped
-- snip --

GDB backtrace gives a hint where it crashed...
-- snip --
#0  0xfe130f00 in nsSocketTransport::doRead (this=0xc09d90, aSelectFlags=7)
    at ../../../../netwerk/base/src/nsSocketTransport.cpp:971
---Type <return> to continue, or q <return> to quit---
971                                                totalBytesWritten);
(gdb) bt
#0  0xfe130f00 in nsSocketTransport::doRead (this=0xc09d90, aSelectFlags=7)
    at ../../../../netwerk/base/src/nsSocketTransport.cpp:971
#1  0xfe12fcbc in nsSocketTransport::Process (this=0xc09d90, aSelectFlags=1)
    at ../../../../netwerk/base/src/nsSocketTransport.cpp:524
#2  0xfe134f84 in nsSocketTransportService::Run (this=0x88e20) at
../../../../netwerk/base/src/nsSocketTransportService.cpp:460
#3  0xff21ccd8 in nsThread::Main (arg=0x87ab0) at
../../../xpcom/threads/nsThread.cpp:83
#4  0xff0f813c in _pt_root (arg=0x89170) at ptthread.c:157
-- snip --

Comment 1

19 years ago
->rpotts
Assignee: gagan → rpotts

Updated

19 years ago
Keywords: beta1, crash
Target Milestone: M14

Comment 2

19 years ago
Tever can you check this on Linux?
Whiteboard: [PDT-]

Comment 3

19 years ago
Daver, I can't reproduce this with the information given on Linux 2000020908.  I 
visited the jpgs listed above without any problems.
(Assignee)

Comment 4

19 years ago
It looks like mReadListener has been corrupted :-(

Tyhe crash is in the call to mReadListener->OnDataAvailable(...)  here's the lxr 
url...
http://lxr.mozilla.org/seamonkey/source/netwerk/base/﷒0﷓
75

Updated

19 years ago
Target Milestone: M14 → M15

Comment 5

19 years ago
Can you verify that it still crashes? Works on Windows now.
(Reporter)

Comment 6

19 years ago
Seems to work on Solaris with recent builds, too.
(But it was a sporadic crash - sometimes working, sometimes crashing ;-( ).

Comment 7

19 years ago
Moving what's not done for M15 to M16.
Target Milestone: M15 → M16

Comment 8

19 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.
Please update target, M16 is long gone

Comment 10

19 years ago
Hi Roland:

Are you still seeing this crash?  I couldn't reproduce it with our recent 
build.  

Comment 11

18 years ago
Is anyone still seeing this crash?  I still cannot reproduce this.

Comment 12

18 years ago
Clearing very old milestone (M16) in hope of reevaluation.
Target Milestone: M16 → ---
(Reporter)

Comment 13

18 years ago
Never saw this in the last months. Seems to be fixed... :-)

Comment 14

18 years ago
reopen if still an issue.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 15

18 years ago
Could not reproduce it on 2001-04-05 win32 mozilla build.
(Reporter)

Comment 16

18 years ago
Work for me with 2001-04-05-08-trunk on Solaris 2.7/SPARC, too.
Problem is gone, burried deeply in it's grave... =:-)

Updated

16 years ago
QA Contact: tever → benc
You need to log in before you can comment on or make changes to this bug.