Can not read Thai Lang on Hotmail

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: Matt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME - 04/10/07, URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

I open hotmail website read email send by thai font.
I set Tools > Options >General > Langauge and Font&Color support thai lang
already.When i read email.It can not read email.I see at View Menu > Character
encoding,Firefox choose Thai(Windows-874).I will click View Menu > Character
encoding > Thai(Windows-874) again.Firefox display correct.

Reproducible: Always
Steps to Reproduce:
1.Open hotmail website and log in
2.See inbox or read email.
3.

Actual Results:  
Firefox display incorrect.I change Character encoding agian.

Expected Results:  
Auto detect and coorect display.

If i open yahoo mail,It display correct.

Comment 1

13 years ago
Tried setting appropriate View>Char encoding>auto-detect option?
Component: Web Site → General
(Reporter)

Comment 2

13 years ago
Created attachment 163925 [details]
Display incorrect
With autodetect on, my experience was exactly the opposite: Hotmail sends the
page with a "Content-Type: text/html; charset=windows-874" header, and Firefox
honors it and correctly (as best I can tell without knowing the language)
displays the page, while Yahoo only sends "Content-Type: text/html" without a
charset, and (I assume) because of all the English surrounding the Thai,
autodetect chooses ISO-8859-1 instead.

Comment 4

13 years ago
Confirmed on Debian Sarge, Firefox 1.0 build 20050611.

The Character Encoding in View menu switch back to Western everytime new page
load. I already set Default Character Encoding to Thai (TIS-620).

I try to view Hotmail HTML source and there isn't any charset information in <head>
Assignee: bugs → nobody
QA Contact: general
Are you still seeing this bug using the latest version of Hotmail and Firefox 2.0.0.3 or later? (Please try using a clean profile as well.)

http://kb.mozillazine.org/Profile_Manager
Whiteboard: CLOSEME - 04/10/07
With no word from someone still seeing this, I'm closing this bug as INVALID. If you can answer the question in comment 5, please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.