Download manager should be opened, but not steal focus, when a download begins

RESOLVED DUPLICATE of bug 231580

Status

Camino Graveyard
Downloading
--
enhancement
RESOLVED DUPLICATE of bug 231580
13 years ago
13 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041029 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041029 Camino/0.8+

Currently Camino opens the download manager *and* steals focus when a download
begins (the first time).  Opening the manager is desirable, but stealing focus
is not.  (On subsequent downloads, as long as the manager has remained open,
focus is not stolen.)

The download manager should *always* open but not steal focus when it does so,
both for consistency and to make it less annoying :)

Reproducible: Always
Steps to Reproduce:
1. Close download manager if it is open
2. Click on link to downloadable file type

Actual Results:  
Focus has shifted from the browser window--in which the user was working--to the
newly-opened download manager.

Expected Results:  
The download manager should open but rthe browser window where the user was
working should retain focus.

Comment 1

13 years ago
Confirming this because its a valid enhancement request. Note however that the
requested functionality (which was deliberately introduced for 2nd and
subsequent downloads, as noted by the reporter) is not universally popular. Bug
231580 asks for the exact inverse of this bug.

If the suggestion from bug 231580 for a pref for this behaviour is accepted then
this bug can be duped against that one. Until then however I guess we have two
competing bugs.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

13 years ago
we gotta pref it, no other way to make everyone happy.

*** This bug has been marked as a duplicate of 231580 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.