Closed Bug 266844 Opened 15 years ago Closed 15 years ago

"OK" disabled for certain mimeTypes.rdf entry

Categories

(Firefox :: File Handling, defect)

x86
All
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 264492

People

(Reporter: syskin2, Assigned: bugs)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

If a file extension has a specific mimeTypes.rdf entry, OK button is disabled
and file cannot be opened or downloaded.

Reproducible: Always
Steps to Reproduce:
1. use mimeTypes.rdf file that I'll attach. This file has an entry for "foobar"
extension and a "value" parameter, like this:

  <RDF:Description
                   NC:fileExtensions="foobar"
                   NC:value="anything">
  </RDF:Description>

2. Open a file with "foobar" extension and served as, for example,
application/octet-stream (to pop up a download dialog)

Actual Results:  
"OK" is disabled - file cannot be downloaded and a helper application cannot be
launched.

Expected Results:  
I don't know what this mimeTypes.rdf says exactly but I guess it shouldn't block
a file, regardless of being valid or not.



This actually happened to me with .jar files and it's not funny at all. The .jar
entry has much more info than this, I can attach (in fact, I will) everything.
The testcase I have is simply the absolute minimum needed to reproduce.
Attached file mimeTypes.rdf
minimum testcase - ".foobar" extension will be broken of this is in your
profile.
This is the .jar entry from my real mimeTypes.rdf file. I don't know if it's
useful. I can't tell how this entry was created, or when - but it was
definitely firefox that created it (ie I wasn't doing it manually with a text
editor).
It is perhaps worth adding that such file type will NOT be listed in
options->downloads->file types. So it's not possible to delete such "broken"
entry using firefox GUI.
Summary: "OK" disabled for certain mimeTypes.rdf entry → "OK" disabled for certain mimeTypes.rdf entry
I've been seeing this on firefox 1.0 fi-FI linux with a lot of file types. I
poked around in mimeTypes.rdf and indeed the misbehaving items are those that
specify fileExtensions. Mine is a bit of a crufty profile though... I moved
mimeTypes.rdf aside, will see if this pops up again.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
<RDF:Description RDF:about="urn:mimetype:video/x-msvideo"
                   NC:fileExtensions="avi"
                   NC:description="Video Clip"
                   NC:value="video/x-msvideo"
                   NC:editable="true">
    <NC:handlerProp RDF:resource="urn:mimetype:handler:video/x-msvideo"/>
</RDF:Description>

Removing above did fix "grey" OK button (with avi files).

*** This bug has been marked as a duplicate of 264492 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.