Firefox RC1-->Sort Bookmarks by name(no extension) doesn't work

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: t1470258, Assigned: vlad)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

I recently downloaded & test the Firefox RC1 from:
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.0rc1/Firefox%20Setup%20(1.0rc1,%20en-US).exe.
But despite the fact Firefox PR can sort, RC1 CAN'T sort the bookmarks by name.

Sad but true; first Firefox lost Mozilla Suite's 'sort by ...' variations like:
URL,date... And now RC1 lost it completely letting us depend on extensions only...

Reproducible: Always
Steps to Reproduce:
1.Choose Menu->Bookmarks->Manage Bookmarks...
2.On right side pane; right-click on a populated folder->choose 'Sort by name'
Actual Results:  
Surprisingly nothing! The folder to be sorted by name remain 'unsorted' as is...

Expected Results:  
The folder chosen should be sorted like it was sorted in Firefox PR & others.
Actually, due to major feedback, we sort siblings, not children.  If you go into
the folder and do the Sort by Name command, it'll sort the contents there.  Its
a change, but its a change for the better, IMO.

Also, we never "lost" Mozilla's sorting functionality, we never
ported/implemented it because we felt that the instant permanance was a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
Thank you for the tip for sorting folders...
I tried, as I used to, click on folder->then choose sort.
Now I learn to sort while 'inside' the folder... Thanks again.

Sorry, but with my ever growing bookmarks (2mb+) I really need 
something for this task. I tried sort 'extensions' based on Java.
Not satisfied I installed the 'Mozilla Suite' just for sorting jobs.

I'd like to ask:
-Do you know any 3rd party that can handle 'new' Firefox icon'ed, etc. 
bookmarks file correctly? I tried some but they can't...
-I know moderate HTML & Javascript(If these count). Can you guide me 
where can I start to learn writing an extension? so that people like me 
can also benefit if I can build one for sorting.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.