Ctrl +F4 works differently to Right Click -> Close Tab when only one tab open

RESOLVED DUPLICATE of bug 266851

Status

()

Firefox
Keyboard Navigation
--
minor
RESOLVED DUPLICATE of bug 266851
14 years ago
14 years ago

People

(Reporter: Matt Davis, Assigned: Aaron Leventhal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041029 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041029 Firefox/1.0RC1

When only one tab is open the Close Tab option on the right click menu is
disabled. In the same situation pressing Ctrl + F4 will cause the open tab to
change to a blank page

Reproducible: Always
Steps to Reproduce:
1. Open Firefox with a single tab open and a webpage loaded
2. Right click on the tab and notice that Close Tab is disabled
3. Press Ctrl + F4

Actual Results:  
The tab changed to the empty page and the title changed to "(Untitled)"

Expected Results:  
Nothing. Ctrl + F4 should have been ignored.
This is assuming that the Right-click menu is correct. I'm not sure which is
correct, all that matters is that the two operations are consistent.

I have the "Hide the tab bar when only one web site is open" option unchecked.
(Reporter)

Comment 1

14 years ago
Sorry, dup

*** This bug has been marked as a duplicate of 266851 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.