If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No BACK or FORWARD buttons working when extensions page opened from the link in the Extension Manager

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Paul Dorneanu, Assigned: Blake Ross)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041029 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041029 Firefox/1.0RC1

There is no back or forward button active when jumping to the extensions page
from  the Extension Manager. My mouse has back and forward buttons which are not
working. But I seem to be able to go back using Backspace key on keyboard. Also,
why Firefox opens extensions page in a new window when my browser is configured
to open all new links into new tabs and not new windows.

Reproducible: Always
Steps to Reproduce:
1. Start Extension Manager.
2. Press "Get More Extensions" link.
3. The extensions page on update.mozilla.org try to follow any link and then go
back to the main page. 
Actual Results:  
You will see that you can not go back or forward because the navigational
buttons do not become active.

Expected Results:  
work
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0 Branch

Comment 1

13 years ago
same problem over here


Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041029
Firefox/1.0RC1 (MOOX M3)


XP  SP2
WFM using
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041030
Firefox/1.0RC2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041028
Firefox/1.0RC1

I'm using the default theme. 

Comment 3

13 years ago
WFM using

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041029
Firefox/1.0RC1

(Windows XP SP2)

I'm using the "Luna Blue" theme.

Comment 4

13 years ago
WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20041026 Firefox/1.0RC1...sorta

Clicking the "Get More Extensions" link opens a new window, even though both
options in Advanced say to open new tabs instead of new windows...and because
it's a new window, the back/forward buttons are disabled.

It shouldn't be opening the window at all, and should be obeying preferences to
open in a tab...dunno if this is a known bug.
The issue of the Get More Extensions link spawning a new window is a totally
unrelated bug, bug 262575. The Tabbrowser Preferences extension can provide the
behaviour you seek for now.

As for the relevant part of comment #0, WFM.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041030 Firefox/1.0RC2
(daihard: P4/SSE2)
(Reporter)

Comment 6

13 years ago
I think this is happening only when there is not a clean install.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug no longer exists, if it ever did - I suspect that the reporter was
experiencing something else, like a borken extension.

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.