If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox takes time to load a big XML-file, this is normal

RESOLVED DUPLICATE of bug 247340

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 247340
13 years ago
4 years ago

People

(Reporter: Moritz Geisberger, Assigned: Blake Ross)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; i-NavFourF)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

By loading this XML-File, Firefox hangs up. It uses the full CPU capacity and 
the memory load rises up to 40MB after ~10 seconds, 80MB after a half minute 
and about 300MBs after one minute, but nothing happens.

Reproducible: Always
Steps to Reproduce:
1. Just start Firefox, enter the URL and press return!
Actual Results:  
Firefox stops working, I've to kill the firefox-process

Expected Results:  
Show the XML-file

Standard installation, no themes or plugins.

Other users confirmed the same bug with the actual RC1 and the Preview-version 
(http://www.klamm.de/forum/showthread.php?t=42177 [german!] for further details)
(Reporter)

Updated

13 years ago
Summary: http://geisnet.dyndns.org/moritz/misc/firefox_xmlbug.xml → Firefox crashes when loading an specific XML-file
Not a crash, or even a hang, for me: more like an annoyance. It took four
minutes to load, burned through close to 250MB before it was done, and was
unresponsive for part of that time, but it did render, and once it was done was
willing to give up most of the memory on min/maximize.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
OK, just tried to wait longer ;)
Just like you said, after 4 minutes of waiting and almost 250MB of memory usage 
it rendered and the processor load slumped back to zero percent, but unlike you 
reported, my firefox continued using 200MB of my memory.
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0 Branch
(Reporter)

Comment 3

13 years ago
Still not fixed in Firefox 1.0 (Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; 
rv:1.7.5) Gecko/20041108 Firefox/1.0)...

Comment 4

13 years ago
reporter: yes, it's true, bugs don't usually go away on their own (i.e. w/o
anyone acting upon them). please don't be surprised by this fact. xml is not
incrementally rendered, which means that for large xml files you won't get any
feedback until gecko finishes chewing. this is not going to be fixed anytime soon.
Summary: Firefox crashes when loading an specific XML-file → Firefox takes time to load a big XML-file, this is normal
Whiteboard: DUPEME

Comment 5

13 years ago
Duping to similar bug 247340.  Reporter, if you feel this was done in error,
please REOPEN.

*** This bug has been marked as a duplicate of 247340 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.