Quit and New Navigator Window commands do not work.

VERIFIED FIXED

Status

SeaMonkey
General
VERIFIED FIXED
14 years ago
14 years ago

People

(Reporter: Pavel, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5) Gecko/20041030
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5) Gecko/20041030

Commands File/Quit and File/New/Navigator Window do not work.

Reproducible: Always
Steps to Reproduce:
1. Select File/Quit or File/New/Navigator Window (or press Ctrl+Q or Ctrl+N)
2.
3.

Actual Results:  
Nothing happens

Expected Results:  
Quit or open new window

Comment 1

14 years ago
I have the same problem on Linux 2004103005; 2004102906 and earlier builds are OK.

Comment 2

14 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041031
Firefox/0.9.1+

File -> New works. I am not yet sure about Quit!

Comment 3

14 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041031
Firefox/0.9.1+

File -> Quit works

Comment 4

14 years ago
Doesn't work on Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.8a5) Gecko/2004103105
or 2004103005. Works on 2004102906 and earlier builds.

Comment 5

14 years ago
Any errors in JS console?

Comment 6

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041031

Neither works for me. 
See bug 237745
(Reporter)

Comment 8

14 years ago
JS console shows in both cases: 
Error: uncaught exception: [Exception... "Component returned failure code:
0x80570018 (NS_ERROR_XPC_BAD_IID) [nsIJSCID.getService]"  nsresult: "0x80570018
(NS_ERROR_XPC_BAD_IID)"  location: "JS frame ::
chrome://global/content/globalOverlay.js :: goQuitApplication :: line 23"  data: no]
(Reporter)

Comment 9

14 years ago
Oops the previous was for quit only.
For new it shows:
Error: uncaught exception: [Exception... "Could not convert JavaScript argument
(NULL value cannot be used for a C++ reference type) arg 0
[nsISupports.QueryInterface]"  nsresult: "0x8057000b
(NS_ERROR_XPC_BAD_CONVERT_JS_NULL_REF)"  location: "JS frame ::
chrome://communicator/content/tasksOverlay.js :: OpenBrowserWindow :: line 120"
 data: no]
*** Bug 267092 has been marked as a duplicate of this bug. ***
Are people seeing this bug using some sort of extensions?  This worksforme with
a vanilla trunk SeaMonkey build from this morning...
*** Bug 267112 has been marked as a duplicate of this bug. ***
Even more interestingly, could someone who sees this error click onthe link in
their JS console and paste into this bug the 2-3 lines of JS around the one that
throws?

Comment 14

14 years ago
(In reply to comment #13)
> Even more interestingly, could someone who sees this error click onthe link in
> their JS console and paste into this bug the 2-3 lines of JS around the one that
> throws?

I'm currently using:  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5)
Gecko/20041102.

I don't see the bug today, but JS console has these 2 errors after
doing File-> NewWindow:

Note :   I think 1st error below  is due to the "//-->" of line 5.
----


<html><head><meta http-equiv="content-type" content="text/html; 0 
charset=UTF-8"><title>Google</title><style><!--                 1
body,td,a,p,.h{font-family:arial,sans-serif;}                   2
.h{font-size: 20px;}                                            3
.q{color:#0000cc;}                                              4
//-->                                                           5
</style>                                                        6
<script>
<!--
function sf(){document.f.q.focus();}
// -->

========================== Errors:  ==============================================
(1)  Error: Selector expected.  Ruleset ignored due to bad selector.
Source File:      http://www.google.ca/
Line: 5



and

(2)   Error: Unexpected end of file while searching for 'closing } of invalid
rule set'.
Source       File: http://www.google.ca/
Line: 6

David, if you're not seeing the error, then the JS console messages you see are
not relevant to this bug.  The messages I'm interested in are the ones listed in
comment 8 and comment 9.
Boris, this was fixed when bug 237745 was fixed, as already referenced in comment 7.
Ah, I see.  It looked to me like it was a regression from bug 237745 and that
bug is too messy to figure our what the heck is going on.

Marking fixed.  People should upgrade to Nov 1 builds or newer.  See bug 237745
comment 52.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Verified FIXED with build 2004-11-12-04 on Windows XP.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.