Closed Bug 267002 Opened 15 years ago Closed 15 years ago

FF does not correctly scroll to the requested anchor on first load when the page contains images without size information

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 60307

People

(Reporter: Athropos, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041030 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041030 Firefox/1.0RC2

The title says it all.

Reproducible: Always
Steps to Reproduce:
1. Go to
http://forum.presence-pc.com/foldinghome/FHGHAidesurleclientfoldinghome/FahMon-v1-7-2b--sujet-486-5.htm#t9323

Actual Results:  
The page is scrolled below or above the anchor

Expected Results:  
The page should have been scrolled exactly to the requested anchor

You can click on the little 'paper' icon on the right of the avatar to see where
the page should have been scrolled.

I think this is caused by the avatars which do not have size information. The
page should be scrolled after the rendering and not before.
Dupe of 60307?
I don't know if this is really a dupe of 60307. If the latter is corrected, this
one will surely be fixed also, but as 60307 is opened since 2000, I think this
is a very difficult bug to fix. This one could be done by simply scrolling after
the rendering IMO. Well, I leave the decision to others...
Yes, this is a duplicate of bug 60307.

*** This bug has been marked as a duplicate of 60307 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.