Some URL patterns are impossible to enter in the popup blocker options

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: red.ghost, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

The popup blocker systematically blocks popup with a certain URL pattern (due to
whitespaces?) - for instance
http://marrach.skotos.net:8080/SAM/Prop/Neoct%3AWriting%3AVerbs%3Acompose/popup?actor=Marrach%3Aplayers%3AO%3Aostane&addressee=&optsig=&sign=&target=%5BNPC%3Amisc%3Ascroll%5D%2342152&this=Neoct%3AWriting%3AVerbs%3Acompose&zid=1775&arghash=4270928949590774294af5e18ad9e94eCreating%20a%20SkyWriter%20popup%20window!
When clicking on the "Firefox has prevented this site from opening a popup
window" bar, and then "Edit popup blocker options" nothing appears in the
"Address of web site" field. Attempts to manually edit the hostperm.1 file
haven't been successful either.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
*** Bug 267004 has been marked as a duplicate of this bug. ***

Comment 2

13 years ago
URLs such as:

http://mail.expertit.uk:3000/WorldClient.dll?Session=BBHQFTS&View=Options-Prefs&ReturnJavaScriptConfirm=yes&Save=Yes&User:PreviewPaneWidth=408&UTF8=Yes

are also blocked by the popup blocker even though the domain mail.expertit.uk is
whitelisted.
Assignee: bross2 → nobody
Is there a live site still around that exhibits this behavior? Additionally, can someone attach a testcase which exhibits this behavior?

Comment 4

12 years ago
This appears to have been fixed in FF2.0.3, it has been such a long time since this was reported!

Many thanks

Daniel
Resolving as WFM since I'm not sure what bug fixed this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.