crash when using a css switcher to switch to an invalid stylesheet

RESOLVED DUPLICATE of bug 231776

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 231776
13 years ago
13 years ago

People

(Reporter: vassily "vr" ragosin, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

When Alternative Stylesheet switcher is used to switch to a stylesheet, that is
not valid, browser crashes.

Reproducible: Always
Steps to Reproduce:
1. Go to ln.hixie.ch/?start=1099214002&count=1
2. Use Alternative page style to switch to "orange" stylesheet.


Actual Results:  
firefox crashes.

Expected Results:  
ignore bad instructions in css.
(Reporter)

Comment 1

13 years ago
Created attachment 164094 [details]
Bad stylesheet causing crash

Because Hixie can probably change the stylesheet, here is an original one that
causes the crash.

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 231776 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.