us.riso.com - the menu does not show up properly on that website

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English US
--
major
RESOLVED INVALID
13 years ago
3 years ago

People

(Reporter: Jerome Tan, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

the menu does not show up properly, the first level of the menu shows up, but
the sub-levels don't, put mouse over the word "Products" then
"Printer-Duplicator" then the sub-level of "Printer-Duplicator" does not show
up, but when I use IE, it does show up

Reproducible: Always
Steps to Reproduce:
1. visit www.riso.com
2. put mouse over "Products"
3. after the menu showed the list put mouse over "Printer-Duplicator"

you won't see the sub-level of that list but it does show up in MS IE

Actual Results:  
nothing happen, the sub-level of the menu does not show up

Expected Results:  
it should show up the menu way down to the smallest level

Comment 1

13 years ago
Your page has a small number of validation errors, I would be suspicious of
this one:

File "tit002:Users:bfowler:Documents:riso.htm"; Line 284:  Document type does
not permit element “<div>” in content of element “<span>”.

You really have to have valid html for css/javascript/dom work such as you
are using.

I can't quite see how you got Dreamweaver to produce the markup of this
site, and you might be able to fix it very easily by asking Dreamweaver
to verify the pages.

(It is a little while since I have used that program ...)
Ben, I doubt the validation error has anything to do with this bug (since we
allow div inside span).

On the other hand, the following errors in the JS console are likely to be relevant:

CSS Error (http://www.riso.com/riso.htm :0.5): Error in parsing value for
property 'left'.  Declaration dropped.
CSS Error (http://www.riso.com/riso.htm :0.11): Error in parsing value for
property 'top'.  Declaration dropped.

If someone can figure out what they're trying to set top/left to, that would be
much appreciated.

Comment 3

13 years ago
I will look at this again, I was working on the basis that the page in
question was slightly modified from a standard Dreamweaver-produced page.

I would be tempted to modify it back if it were mine!

I am certainly not suggesting that there is likely to be a defect in
Firefox.
Product: Browser → Seamonkey

Comment 4

13 years ago
on line 700 of http://us.riso.com/mm_menu.js, it does:

left = (parseInt(menuLayer.style.width)-4*l.Menu.menuBorder) + 
         parseInt(menuLayer.style.left) + l.Menu.submenuXOffset;

menuLayer.style.width evaluates to "" because the width had not been set.  So
parseInt evaluates to NaN and things go downhill from there.  There were also
several places it used "visibility:hide", which should be "visibility:hidden"
except in a few places where fixing it actually broken the page.

==> Tech Evang
Assignee: general → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
Keywords: qawanted
Product: Mozilla Application Suite → Tech Evangelism
QA Contact: general → english-us
Summary: the menu does not show up properly on that website → us.riso.com - the menu does not show up properly on that website
Version: Trunk → unspecified

Comment 5

13 years ago
oh, and it should be using getComputedStyle instead
http://www.mozilla.org/docs/dom/domref/examples.html#998756
Site has been updated, not using the mouse over menu anymore. Closing.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.