Closed Bug 267063 Opened 17 years ago Closed 10 years ago

Shutdown crash in ~nsJSRuntimeServiceImpl [@ free - js_FinalizeStringRT]

Categories

(Core :: XPConnect, defect)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
mozilla12

People

(Reporter: darin.moz, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [needs stack evaluated for usefulness - xpconnect])

Crash Data

Attachments

(3 files)

Shutdown crash in ~nsJSRuntimeServiceImpl

I'll attach a stack shortly.  Not sure if this is really xpconnect's fault, but
it seems like a reasonable place to start.
Attached file stack trace
This stack trace was taken with a CVS trunk build (up-to-date as of today) of
Firefox on Linux.  I didn't do much more than run the browser and then close
it.
Attached file another stack
here's another stack.  in this case, i just loaded firefox w/ default homepage,
and then pressed the close button.

this stack seems to implicate JS_GC ...
Interestingly enough, I cannot reproduce this crash when running under valgrind :(
This crash, or at least one with a similar JS_GC stack, is still happening with
CVS trunk as of 11/5 on Linux.  Again, I cannot catch it in valgrind.
Assignee: dbradley → nobody
QA Contact: pschwartau → xpconnect
Attached file TB25676224W
TB25676224W : similar stack trace, but on BonEcho 2.0 (mozilla1.8 branch)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061106 BonEcho/2.0
Build ID: 2006110604
This is a crash: please raise severity to "critical" and add "crash" keyword.
Maybe also mention "1.8 Branch" in Version.
Severity: major → critical
Keywords: crash
Summary: Shutdown crash in ~nsJSRuntimeServiceImpl → Shutdown crash in ~nsJSRuntimeServiceImpl [@ free - js_FinalizeStringRT]
Whiteboard: [needs stack evaluated for usefulness - xpconnect]
Crash Signature: [@ free - js_FinalizeStringRT]
Depends on: 711826
Code is gone.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → mozilla12
You need to log in before you can comment on or make changes to this bug.