Last Comment Bug 267082 - unable to manage subscriptions when folder is undeleted
: unable to manage subscriptions when folder is undeleted
Status: RESOLVED FIXED
[fixed by bug 711173/bug 705504]
:
Product: MailNews Core
Classification: Components
Component: Feed Reader (show other bugs)
: Trunk
: All All
: -- major with 11 votes (vote)
: Thunderbird 13.0
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 280218 284455 286343 293137 293167 (view as bug list)
Depends on: 711173
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-31 17:07 PST by james.fraser
Modified: 2012-02-19 03:25 PST (History)
18 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description james.fraser 2004-10-31 17:07:17 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

Using Thunderbird 0.8
If you choose to Store Feed Articles from several feeds in a single folder, then
delete the folder, then undelete in, you are no longer able to manage
subscriptions for those feeds.  They are no longer present in the manage feeds
menu.  However, the feeds are still active.

Reproducible: Always
Steps to Reproduce:
1. Add a new feed and Store Feed Articles in "Test Feeds"
2. Add a second feed and Store Feed Articles in "Test Feeds"
3. Delete the Folder "Test Feeds"
4. Move Folder "Test Feeds" back from Trash to "News & Blogs"
5. Attempt to Manage Subscriptions for RSS feeds

Actual Results:  
Can no longer Manage the Settings for the RSS feeds.  Feeds still arrive in
"Test Feeds" folder

Expected Results:  
When folder was undeleted, it should also undelete the feeds in the Manage
Subscriptions so that they can be edited or deleted individually.  This is a
pretty serious defect in a very useful feature.  I like to send several related
feeds to one folder, but can no longer manage those feeds if I accidently delete
the folder.

Using Windows XP Pro
Thunderbird 0.8 (20040913) - no themes
Comment 1 Adam Lewandowski 2005-01-18 12:31:48 PST
I can confirm this behavior, even when not using a single folder to store all
feeds. 
Also, when you undelete the folder, you loose the setting for "Show the article
summary instead of loading the web page" if you had it selected.
I often accidentally delete the feed's folder when trying to delete a single
message and run in to this quite often. The workaround is to re-add the feed but
it's kind of a pain.
Comment 2 Mike Cowperthwaite 2005-02-06 11:39:09 PST
(In reply to comment #0)
> If you choose to Store Feed Articles from several feeds in a single folder

This is true for a single feed into a folder as well, and applies if the folder 
is the default one created for the feed rather than one specified.

> 3. Delete the Folder "Test Feeds"

TB does not ask for confirmation on folder deletion -- see bug 281105.  
This makes accidental deletion a real problem.


> 4. Move Folder "Test Feeds" back from Trash to "News & Blogs"

Note that there is no "Undo Delete Folder" feature, altho that is true for Mail 
accounts as well.


Reproduced with TB 1.0, Win2K.
Comment 3 Mike Cowperthwaite 2005-02-06 11:39:43 PST
*** Bug 280218 has been marked as a duplicate of this bug. ***
Comment 4 Mike Cowperthwaite 2005-03-02 10:15:45 PST
*** Bug 284455 has been marked as a duplicate of this bug. ***
Comment 5 Mike Cowperthwaite 2005-03-16 07:00:07 PST
*** Bug 286343 has been marked as a duplicate of this bug. ***
Comment 6 Eric Schultz 2005-03-18 08:50:09 PST
I posted a message about this bug in the forums (before I realised it was a
reported bug):
http://forums.mozillazine.org/viewtopic.php?t=236173&highlight=

What I noticed was I check in the feeds.rdf file (in
%AppData%\Thunderbird\Profiles\myProfile\Mail\News & Blogs) and I only find
RDF:Description references, none of the fz:feed entries! 

I suppose a work around would be manually re-enter the fz: elements.  A simple
fix would be re-create with default fz: elements.  And the real fix would be to
pre-serve those fz: elements in the Trash too and undelete them at the same time
as the rest of the config.
Comment 7 Pascal B 2005-05-13 01:24:22 PDT
(In reply to comment #6)

> I suppose a work around would be manually re-enter the fz: elements.  A simple
> fix would be re-create with default fz: elements.  And the real fix would be to
> pre-serve those fz: elements in the Trash too and undelete them at the same time
> as the rest of the config.

I tried correcting feeds.rdf, it is not enough as I still can't manage those
feeds. It seems something more is needed.

Comment 8 Mike Cowperthwaite 2005-09-07 07:25:24 PDT
*** Bug 293167 has been marked as a duplicate of this bug. ***
Comment 9 Mike Cowperthwaite 2005-09-07 07:25:59 PDT
*** Bug 293137 has been marked as a duplicate of this bug. ***
Comment 10 Pontus Freyhult 2005-09-08 22:46:36 PDT
The same (?) issue seems to occur in branch builds simply my moving the feed
folder in the folder pane, which I think is rather bad (very confusing for
normal users).
Comment 11 Jesus Cea 2005-10-04 05:01:36 PDT
Issue still alive in Thunderbird current nightly builds.
Comment 12 Evgeniy Karyakin 2005-10-24 01:28:08 PDT
> > I suppose a work around would be manually re-enter the fz: elements.
> I tried correcting feeds.rdf, it is not enough as I still can't manage those
> feeds. It seems something more is needed.

Also /RDF:RDF/RDF:Seq/RDF:li elements need to be added. Look at ones that are exist and add another ones for feeds you're trying to restore. At least it worked for me.
Another pain is feeds whose titles are not in ASCII -- you should write its title (fz:feed@dc:title) and storing folder (fz:feed/fz:destFolder) in UTF-8 encoding (in raw and urlencoded %AA%BB%CC format respectively), and you not always have UTF-8 editor next to you.
Comment 13 Eric Schultz 2005-12-13 12:27:44 PST
(In reply to comment #11)
> Issue still alive in Thunderbird current nightly builds.
> 

And in version 1.5 (20051201) - RC2 - those subscriptions that were in your profile when you upgrade are still not manageable.  Though they show up in the subscriptions dialog, if you click on Edit nothing happens.  The Title and Location are populate though below the tree view.
Comment 14 Ryan Cannon 2006-02-10 08:30:37 PST
In addition, a feed deleted through context menu or dragged to the trash cannot be re-subscribed. Instead, Thunderbird displays an error Alert:

"You already have a subscription to this feed."

Is this the same bug, or should I file a new one?
Comment 15 zanezane.net 2006-10-25 09:35:51 PDT
I can confirm the bug is still present in 2.0 trunk
Comment 16 Mike Cowperthwaite 2008-02-17 11:58:53 PST
Note that there has been a fix submitted for bug 375745 which may improve the situation of this bug -- it makes the Subscribe dialog behave a little more sanely when feeds are deleted.

(In reply to comment #0)
> Actual Results:  
> Can no longer Manage the Settings for the RSS feeds.  Feeds still arrive in
> "Test Feeds" folder

What I see currently with TB version 3.0a1pre (2008021703), Win2K, is that if I delete the folder, then drag it back from Trash to the top level of the RSS account, then open the Subscribe dialog: the folder appears with an empty feed node underneath it.

I can then delete the node, and TB appears to do that correctly.  Then I can 
re-Add the subscription to that folder, and it takes.  However, after the feed has been verified, there are two feed items shown under the folder.  I can then delete one, and all appears OK.  But, since both are shown as the same URL, I'm not sure which is some ghost version of the original, and which is the new.
But I need to test further to make sure the new items arrive as expected.
Comment 17 ovidiu 2008-05-13 10:10:59 PDT
is this a dupe or related to bug 309449
both have some activity

cannot really reproduce on version 3.0a1 (2008050715)
delete and then drag back has no problem here ..

does bug 365192 has anything to do with it?
Comment 18 alta88 2012-02-14 13:01:35 PST
fixed by bug 711173/bug 705504.

Note You need to log in before you can comment on or make changes to this bug.