Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Messenger ignores MIME charset label

VERIFIED FIXED in M5

Status

MailNews Core
MIME
P2
normal
VERIFIED FIXED
19 years ago
9 years ago

People

(Reporter: lchiang, Assigned: rhp (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
<Initial description transferred from bugsplat bug 333117.  Assigning to phil
for now because jefft and bienvenu do not yet have a bugzilla account>

Messenger ignores MIME charset label

Messenger always ignores the value of the charset= parameter of the
Content-Type: header of the text part it is displaying.


------- Additional Comments From phil  11/14/98 22:42 -------

Bob and Naoki, any comments on our capability to support this?

Comment 1

19 years ago
Setting all current Open/Normal to M4.
(Reporter)

Updated

19 years ago
QA Contact: 4109
(Reporter)

Comment 2

19 years ago
qa contact to pmock for now

Updated

19 years ago
Assignee: phil → rhp

Comment 3

19 years ago
Reassigning to Rich Pizzarro
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

19 years ago
Should be able to deal with this in the new emitters.

- rhp
(Assignee)

Updated

19 years ago
Target Milestone: M4 → M5
(Assignee)

Comment 5

19 years ago
Setting to M5 for now. Does anyone have an example of this that I could use.
Thanks.

- rhp

Comment 6

19 years ago
Adding nhotta and bobj to cc: list.
Latin1 example can be easily created by 4.5.
1) In the subject field hold "Alt" key and type 0201 in the num key then release
the "Alt". You should be able to see É.
2) Make sure that MIME encoding is enabled in the pref.
3) Sent out header should contain
Subject: =?iso-8859-1?Q?=C9?=
4) If the MIME decoder is properly hook up, É should be seen for the above line.

Comment 7

19 years ago
Rich, can this be done for M4? This was working for M3.
I think we just need to hook up the MIME decoder.

Comment 8

19 years ago
Also, if you change the "iso-8859-1" to "iso-8859-5" you should see something
other than latin capital letter E with acute.
(Assignee)

Comment 9

19 years ago
Sorry, but my development system has imploded as of yesterday at noon and I
really dont have a stable build environment. I have some changes that I've
salvaged that I need to checkin today, but that is about all I will be able to
do. Sorry :-(

- rhp

Comment 10

19 years ago
I think this has been fixed but the verification is blocked by XML UTF-8 bug.
Rich, is there way to verify this (e.g. by view source)?
If so, please change the status to 'FIXED'.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

19 years ago
If the problem here is that the UTF-8 conversion is getting truncated, then the
view source will look truncated as well. I think this should remain fixed,
(which it is) and the verification will have to wait on the other bug.

- rhp

Comment 12

19 years ago
Verification depends upon a fix for
http://bugzilla.mozilla.org/show_bug.cgi?id=4968

Comment 13

19 years ago
The main blocker of this is the XML bug #4463.

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 14

19 years ago
The MIME decode is done but I am seeing ISO-2022-JP string appears in the view
instead of UTF-8.
After MIME decode, we need to convert from the charset returned by MIME decoder
to UTF-8.

Updated

19 years ago
Resolution: FIXED → ---

Comment 15

19 years ago
Clear the resolution.
I think Rich has a fix, waiting for the tree to open.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

19 years ago
Got these changes FINALLY checked in so this should be fixed. Thanks naoki :-)

- rhp

Comment 17

19 years ago
Verified on the in the April 27 Win32 build (build id 1999042708).  When I send
my a message to myself that contain an accented character the received message
header contains the string "=?iso-8859-1?Q?=C9?=".

On Linux build (build id 1999042708), I have not been able to verify on this
platform because, there doesn't appear to be an easy way to generated accented
characters.
I have asked a couple of unix engineers but they didn't know.  It was
suggested to talk to Akkana so I emailed her.

Side note, the only information I found was on our international qa web page,
http://home.netscape.com/eng/intl/accentinput.html  In previous projects, I got
around this problem by sending myself a message from windows that
contained the desired accented character then doing a copy and paste.
Unfortunately, copy and paste is not implmented.

Final verification is pending...

Comment 18

19 years ago
Peter, we need to test this for a variety of charsets to see
if this is working.Please re-assign this bug verification to me.

Updated

19 years ago
QA Contact: 4109 → 1308

Comment 19

19 years ago
Received message to Akkana. You can copy and paste the accented character in.
I was able to test the bug successfully. It didn't work for me previously
because I was still using Alt+C and Alt+V.  I didn't know the short cut keys
changed from Nova to Ctl+C and Ctl+V.  It works on Linux.

Per Momoi request, I am reassigning this bug to him for final verification.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 20

19 years ago
** Checked with 4/29/99 Win32 and Linux builds **

We are now able to display headers and body of messages in
many different languages without switching the encoding menu.
(In fact, at this stage, the encoding menu for Mail lists
only Latin1 and Japanese.) As long as we have the right fonts --
I use the new Bitstream Cyberbit 2.0 font for this purpose --
we can display the following languages headers and body without
doing anything on the part of the user, which is what this bug
fix addresses.

http://terra/eng/projects/new5.0/i18n-milestones.html#Converter-milestones

The list of converters to/from Unicode enabled up to M5 can be
found at the above URL. I've confirmed that the following charset
msgs can be displayed on Windows:

ISO-8859-1 (French, German)
ISO-8859-2 (Czech)
ISO-8859-4 (Estonian: Baltic)
ISO-8859-7 (Greek)
ISO-8859-9 (Turkish)
Japanese: ISO-2022-JP
Korean (EUC-KR)
Traditional Chinese (Big5)
Simplified Chinese (Gb2312)
Cyrillic (KOI8-R)
UTF-8

On Unix/Linux, display seems correct only for Japanese and Latin 1,
but this is currently a known limitation on Unix where GFX nulti-
font rendering needs to be implemented properly.

All the above shows that charset label honoring is now in
place. Marking the fix verified on Win32 and Linux.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.