Closed Bug 26710 Opened 22 years ago Closed 20 years ago

CSS2 display: marker, etc. not supported

Categories

(Core :: CSS Parsing and Computation, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED WONTFIX

People

(Reporter: bernd.mielke, Assigned: dbaron)

Details

(Keywords: css2, Whiteboard: [CSS2-12.2])

The () are behind the number instead of beeing around .

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">
<HTML>
 <HEAD>
 <TITLE>Content alignment in the marker box</TITLE>
<STYLE type="text/css">
LI:before { display: marker; content: "(" counter(counter) ")";
counter-increment: counter; width: 6em; text-align: center; } </STYLE> </HEAD>
<BODY>
<OL>
<LI> This is the first item.
<LI> This is the second item.
 <LI> This is the third item.
</OL>
</BODY>
This is a copy from the CSS2 Specification (generate.html)  an below is the
expected result copied from the specification.
<PRE>
  (1)    This is the first item.
  (2)    This is the second item.
  (3)    This is the third item.
</PRE>

</HTML>
We won't have support for CSS2 markers for version 1.0
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → LATER
Marking verified late.
Status: RESOLVED → VERIFIED
LATER is deprecated per bug 35839.
Status: VERIFIED → REOPENED
Keywords: css2
Resolution: LATER → ---
Whiteboard: [CSS2-12.2]
->style system
Assignee: troy → dbaron
Status: REOPENED → NEW
Component: Layout → Style System
QA Contact: petersen → ian
Summary: CSS2 Error with list display → CSS2 display: marker, etc. not supported
->WONTFIX.  We should implement what the CSS3 list module has (when it comes
out), which will probably not be 'display: marker'.
Status: NEW → RESOLVED
Closed: 22 years ago20 years ago
Resolution: --- → WONTFIX
good plan
Status: RESOLVED → VERIFIED
I think this should be re-opened, since bug 205202 was marked "wontfix" on the
grounds that CSS3 shouldn't yet be supported. It's really silly to not implement
the CSS2 way of doing things because CSS3 will do it differently, and at the
same time not implement the CSS3 way because CSS3 isn't finalized yet... and in
the meantime website authors have to wait endlessly for CSS3 to come out.
Bug 205202 has been re-opened, so I withdraw my previous comment. Gracias!
I think technically this is a dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=14983.

Linking to the current active bugs on this subject: display: marker won't be
implemented (https://bugzilla.mozilla.org/show_bug.cgi?id=14983) -- instead
mozilla will eventually "Support CSS3's ::marker pseudo element"
(https://bugzilla.mozilla.org/show_bug.cgi?id=205202).
You need to log in before you can comment on or make changes to this bug.