Back button is not enabled until the third page in the history of a new window, not 2nd.

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Cameron Layne, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

Opening any web page in a new window or tab by any means (ie. from the "Open a
new window" toolbar button, File menu, Right-click a link and choose new window
or tab, or desktop shortcut, etc.) and then clicking a link will not enable the
Back button.  The Back button is not enabled until the third page in the history
of a new window, not the second as you would expect.

Reproducible: Always
Steps to Reproduce:
1. Open a page that contains links in a new window from the File menu, context
menu, or desktop shortcut, etc.
2. Click on a link in that new window.
3. Note the lack of a back button to return to the previous page :(.
4. Click on a link in this second page.
5. Note that we do now have a back button to return to the previous page.  But
we still cannot return to the page before that (ie. the first page in the
history.)  Note: you can get there by the Go menu (so the history is accurate,
just not the Back button.)

Actual Results:  
Page history starting with a new window:
1st page --> No Back button as expected (nothing to go to.)
2nd page --> No Back button (BROKEN!, Should be able to get to the first.)
3rd page --> Back button is now enabled.

Expected Results:  
Page history starting with a new window:
1st page --> No Back button as expected (nothing to go to.)
2nd page --> Back button is now enabled.
(Reporter)

Comment 1

14 years ago
The very first window created upon starting the brower is not affected (it works
correctly.)

Comment 2

14 years ago
WFM
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041030
Firefox/1.0RC2

The version you are using is more than a month old. Can you please see if you
can reporduce this on a newer version from
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-0.11/.

Comment 3

14 years ago
Maybe you are experencing Bug 99091
(Reporter)

Comment 4

14 years ago
Still occurs in
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041101
Firefox/1.0RC2

I was wrong before:  new tabs are unaffected, just new windows.


No.  I do not believe it is Bug 99091.

The urls in my history are unique beyond case.

And I believe the browser is catching the history correctly because an entry is
added to the Go menu (which also has history beyond the new window)..  Just the
 Back button is not being enabled.


  Here is a specific example:

Set your homepage to Google.

Choose File --> New Window. -- http://www.google.com/index.html
Click on "About Google". ----- http://www.google.com/about.html
Click on "Privacy Policy". --- http://www.google.com/privacy.html

You won't be able to return to http://www.google.com/index.html using the Back
button.

Comment 5

14 years ago
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041031
Firefox/1.0RC2
(Reporter)

Comment 6

14 years ago
Okay I found the problem:
The condition appears when I install the extension "Web Developer 0.8" and
disappears when I uninstall it.

Sorry for not removing my installed extensions to remove them from the picture.

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.