If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

jpeg image moves and becomes offset within container when selected with mouse

RESOLVED WORKSFORME

Status

()

Core
Layout: Images
RESOLVED WORKSFORME
13 years ago
5 years ago

People

(Reporter: Paul Bowsher, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20110902][testday-20120713], URL)

Attachments

(4 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

When selecting a JPEG image with the mouse, the image becomes offset within the
container, normally to the bottom left. The layout of the page isn't affected,
as the <img> container doesn't move. 

Reproducible: Always
Steps to Reproduce:
1. Visit a website with a JPEG image inside a selectable (clipboard style) <img>
tag (background images are not affected).
2. Drag and select over the image in the normal way.

Actual Results:  
The image becomes offset, cropping the bottom and left edges by the same offset.
Image is highlighted.

Expected Results:  
Image should be highlighted ready for Cut/Copy. Image should not move

Comment 1

13 years ago
I was unable to reproduce this.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041030
Firefox/1.0RC2

Paul: can you upload a screen shot of this. Please can you also test this with a
newer version from
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-0.11/. The version
you are using is a month old.
(Reporter)

Comment 2

13 years ago
Created attachment 164173 [details]
Requested  screenshot
(Reporter)

Comment 3

13 years ago
Created attachment 164174 [details]
Screenshot of latest nightly build

Installed latest nightly build, bug still there, now i've lost my mouse
gestures and ultrabar :P

Comment 4

13 years ago
Created attachment 164182 [details]
Testcase

Sorry to be such a pain.
Do you experence this problem with this testcase?
(Reporter)

Comment 5

13 years ago
Created attachment 164183 [details]
New SS w/border:solid;

Testcase was fine. Added border:solid; to my testcase, still no joy
Keywords: qawanted
(Reporter)

Comment 6

12 years ago
Just tried with a fresh install of Firefox 1.5 beta 1 on the same windows
installation. Same problem. It appears to happen when the image being dragged
over is in close promixity to other images.
Assignee: jdunn → nobody

Comment 7

6 years ago
Hi Paul,

I have a little difficulty understanding this problem so i'm just going to ask if this is something you see as still needing to be fixed?

Best, Paul

Updated

6 years ago
Whiteboard: testday-20110902

Updated

6 years ago
Whiteboard: testday-20110902 → [testday-20110902]

Comment 8

5 years ago
Comment on attachment 164182 [details]
Testcase

><html>
>	<head>
>		<title>Testcase for Bug 267129</title>
>	</head>
>	<body>
>		<img src="http://www.mozilla.org/media/img/home/firefox.png" style="border: solid;"/>
>	</body>
></html>

Comment 9

5 years ago
WFM on attached testcase with both release and nightly, reporter, do you still see the problem?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0

Updated

5 years ago
Whiteboard: [testday-20110902] → [testday-20110902], [testday-20120713], [closeme 2012-08-01]
[testday-20120713]

I cannot load the testcase, it may have been deleted.

Anyways, I cannot reproduce on the latest Nightly.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0
Windows 7 x64

Steps Taken:
1. Go to http://money.cnn.com/technology/brainstormtech/?iid=F_F500M
2. Scroll down a bit to Flickr Feed which contains a row of jpeg images in close proximity
3. Highlight the row of jpeg images from left to right starting with the first image
4. Images become highlighted without moving at all
(Reporter)

Comment 11

5 years ago
I no longer use firefox and thus am unable to test this bug. Is it possible to remove me from notifications?

Comment 12

5 years ago
(In reply to Paul Bowsher from comment #11)
> Is it possible to remove me from notifications?
Don't think so, but I just close bug then, so there would be no need to write something here and you don't get notifications anymore. This would be the last one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
Whiteboard: [testday-20110902], [testday-20120713], [closeme 2012-08-01] → [testday-20110902][testday-20120713]
You need to log in before you can comment on or make changes to this bug.