If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

JavaScript bookmarklet for moving and resizing active window fails to correctly position window on second monitor when dual display is used

RESOLVED DUPLICATE of bug 62395

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 62395
13 years ago
13 years ago

People

(Reporter: Mark Jones, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

The above URL is an example of a set of javascript bookmarklets I use with
multiple browser windows. This bookmarklet should position the window in the
centre of the active display, sized to a quarter of the current resolution.
Instead the window is aligned with the left edge of the display. The JavaScript
resize works correctly.

Reproducible: Always
Steps to Reproduce:
1. Enable JavaScript
2. Set above URL as a bookmark location
3. Activate the bookmark

Actual Results:  
Window resizes to quarter-display, but repositions to upper-left-hand corner.

Expected Results:  
Window resizes as described, but repositions to the centre of the screen.
(Reporter)

Comment 1

13 years ago
I should have noted the above occurs when the window is open on the SECOND
display of a DUAL DISPLAY XP system.

Apologies for the oversight.
Summary: JavaScript bookmarklet for moving and resizing active window fails to correctly position window on second monitor when dual display is used → JavaScript bookmarklet for moving and resizing active window fails to correctly position window on second monitor when dual display is used

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 62395 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.