Last Comment Bug 267224 - clipPath can't handle complex structure
: clipPath can't handle complex structure
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
-- normal (vote)
: ---
Assigned To: General SVG Bugs
: Hixie (not reading bugmail)
: Jet Villegas (:jet)
Mentors:
Depends on: 193825
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-01 15:12 PST by tor
Modified: 2009-01-09 16:18 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
SVG-code that is broken because of this bug (952 bytes, image/svg+xml)
2006-03-10 06:45 PST, hum
no flags Details

Description User image tor 2004-11-01 15:12:09 PST
The current implementation of clipPath can't handle clipPaths which
have elements with different clip-rule properties or that reference
other clipPaths.
Comment 1 User image hum 2006-03-10 06:45:51 PST
Created attachment 214669 [details]
SVG-code that is broken because of this bug

The attached svg file works correctly in Adobe SVG Plugin (shows only red rectangle) but not in FireFox 1.5 (shows black borders around red rectangle).

(The SVG code has clipPath-definition referencing another clipPath)
Comment 2 User image tor 2006-10-06 15:11:51 PDT
WFM on the trunk.
Comment 3 User image Jason Bassford 2006-10-07 06:47:02 PDT
Fixed by bug 193825 (I assume).

Note You need to log in before you can comment on or make changes to this bug.