Filter from POP imbox to IMAP folder fails

RESOLVED DUPLICATE of bug 210614

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 210614
14 years ago
14 years ago

People

(Reporter: Mikhail Ramendik, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)
Build Identifier: version 0.8 (20040913)

I use Thunderbird 0.8 on Linux (RH9-derivative). I am using an IMAP server for 
local storage (DbMail).  
 
I tried to set up a filter so that certain messages get moved directly to IMAP 
folders on reception. But when I try to get mail, TB says that the filtering 
has failed "because another operation is in progress". 
 
"Receiving" IMAP mail before receiving POP mail does not change things. But 
manually applying filters later appears to work. 
 
This seems to be reliably happening with IMAP folders that were not opened 
before, or got a large amount of new mail since they were last opened (even by 
TB copying). 

Reproducible: Always
Steps to Reproduce:
1. Set up an IMAP account and a POP account 
2. Set a filter from the POP acount's INBOX to the IMAP account's folder. 
3. Put some 1,000 messages into the same IMAP folder, don't open it with TB. 
4. Send a mail that will suit the filter to the POP account. 
5. Receive mail on the POP account 
 
Actual Results:  
A message informing that the filtering has failed "because another operation 
is in progress". 

Expected Results:  
Move the message to the IMAP folder

Comment 1

14 years ago
See in particular bug 210614 comment 5.

*** This bug has been marked as a duplicate of 210614 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.