Closed Bug 267281 Opened 15 years ago Closed 15 years ago

Upgrades to rendering engine should be silent and automatic, by default

Categories

(Toolkit :: Application Update, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 266487

People

(Reporter: m.ward, Assigned: bugs)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041031 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041031 Firefox/1.0RC2

After reading an article from Mike Davidson (see url above), I beleive that
Firefox should support the automatic and silent installation of upgrades to the
rendering engine by default.

Upgrade cycles in the browser industry are currently long. The upgrade cycles
for Firefox are still good, but that relies on the relatively techie nature of
the current installed user base - as our market penetration begins to increase
then the upgrade cycle is likely to slow.

My argument depends on the capability of the rendering engine to be installed
seperately to the chrome and UI, on an automatic and silent basis, facilitating
the uptake of newer versions of the rendering engine with improved standards
support.

Compatiblity of older browsers is a problem for web developers, but the problem
could be reduced if a self-upgrading browser held a strong position in the
browser market.

This feature could have a UI preference setting to allow it to be disabled
(particularly for use in corporations, who would desire a stable feature set).

Browser chrome and interface upgrades could be bundled seperately with the
rendering engine through the current upgrade mechansim.

I admit I am not intimately familiar with the internal workings of Firefox, so
this enhancement is for others to dissect. I simply hope that my proposal is
seen as desirable.

Reproducible: Always
Steps to Reproduce:
1. N/A
2.
3.
I think it already works like this. We already have the GRE (Gecko Rendering
Engine) internally. Although it's still statically linked, it might become a
shread library in the future (so that it can be shared by Firefox, Thunderbird,
Sunbird, ...), which could be updated on its own.
Note that FireFox does already have auto-update functionality - its just that
its not silent - the user gets to see it happen, which IMO is for the best.
At least the update system should allow the user to use the browser while the
upgrade is made.
(In reply to comment #2)
> Note that FireFox does already have auto-update functionality - its just that
> its not silent - the user gets to see it happen, which IMO is for the best.

It does have auto update, but it updates the entire app - UI and rendering engine.

I propose that the rendering engine should be upgradable on it's own -
effectively allowing the latest rendering engine to be in use, with no
perceprtable difference to the end user.

End users (generally) don't like things changing, so we can give them the latest
technology with no learning curve.

End user will be happy because they only need to upgrade their application when
they want to, and developers will be happy because of the quick uptake of new
versions of the rendering engine.
I think the intention that this should happen similar to the way flash updates
itself. Appearing very simple and quick to the user.
We don't distinguish between the rendering engine and the frontend yet, although
that is in the works (xulrunner). But changes to the backend often requires
changes to the frontend and vice versa, so it won't be possible to update only
one of them.

*** This bug has been marked as a duplicate of 266487 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.