Text enclosed within HTML comments tags still displays

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: dowd, Assigned: bugzilla)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

In the page http://fatherdowd.blogspot.com, there is a large section of text at
the end of the page enclosed within comments tags (i.e. the <!-- and --> tags).
 This is WML data which is not meant to be displayed in a regular web browser
like Explorer or Firefox.  Explorer does not display it, but Firefox does.

Reproducible: Always
Steps to Reproduce:
1. Load the page, and scroll to the end.  The text is plain to see.
2. Do a View, Page Source.  You will see that the comments begin to display
somewhere in the middle of the commented text, at this line:

<p><a href="#109923051777919529" >Baptismal ministry -- ramping things up</a>

Note the two dashes, followed (much later) by a '>'.  The engine is interpreting
this as a close of the comments tag, so everything after is displayed.  That
can't be right.
Actual Results:  
Exactly what I describe.

Expected Results:  
It should close the comments only at the 'EndWAP-->' line, just before the
</body> tag, and not before.  Explorer does this correctly.

I'm listing this as major simply because the comments tags are all over the
place in the Web, and if this break them then it will be a major issue.

Updated

14 years ago
Component: General → HTML: Parser
Product: Firefox → Browser
Version: unspecified → 1.0 Branch
A closer look at the source reveals the following line, about 20 lines after the
"<!--StartWAP" line:

<p><a href="#109923051777919529" >Baptismal ministry -->

That "-->" at the end is (correctly) closing the comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
My bad - I was relying of the "View Source" - which apparently got confused as
well. Reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

14 years ago
(In reply to comment #0)
> Note the two dashes, followed (much later) by a '>'.  The engine is interpreting
> this as a close of the comments tag, so everything after is displayed.  That
> can't be right.

That's exactly right.  You cannot have -- in a comment, because that closes the
comment. See http://www.w3.org/TR/html401/intro/sgmltut.html#idx-HTML
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → INVALID
This is also a duplicate of Bug 237261 (resoved as INVALID, for the reason given
in comment #3).
Bah - I meant duplicate of bug 233270, which was resolved as "INVALID".
I'll go get some sleep now and stop causing damage.
You need to log in before you can comment on or make changes to this bug.