The first list entry is always selected from the dropdown box

VERIFIED WORKSFORME

Status

Thunderbird
Message Compose Window
--
minor
VERIFIED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Damien O'Donoghue, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: 

When typing the first few letters of a name, a list of matches appears in a 
dropdown box.
Using the 'down arrow', I can successfully select any entry in the list and 
pressing ENTER adds it to the list of recipients.
If I use the mouse to select an entry, most* times, the first entry in the list 
is selected.

*See Additional information

Reproducible: Sometimes
Steps to Reproduce:
1. Type a character in the 'To' field that will result in more than 1 match
2. Use the mouse to select an entry in the list that is not the first
3. Left click to select the list entry

Actual Results:  
The first entry in the list was selected

Expected Results:  
The selected list entry should have been added.

1. Assuming I typed 'ch' in 'To' field.
2. The following dropdown list was displayed:
  nita chow <nita.chow@blah>
  chad down <chad.down@blah>
  mitch walters <mitch.walters@blah>
3. I selected 'chad down' using the  mouse.
4. nita chow was added to the 'To' field.

*I could reproduce the problem whenever I created a new email, but after I 
added a few more To or CC fields to the email, the problem seemed to resolve 
itself.

NOTE: Using version 0.8 (20040913)

Comment 1

13 years ago
I am unable to reproduce this symptom with TB 0.9, Win2K.
Damien O'Donoghue, is this bug still a problem for you with current builds?
If not, please mark this bug:  Resolved | WorksForMe
(Reporter)

Comment 2

13 years ago
Tested v0.9...and it now works correctly
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.