Closed Bug 267439 Opened 17 years ago Closed 11 years ago

Save All Attachments should not display a download window for each file

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mozilla.jgvons, Unassigned)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041031 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041031 Firefox/1.0RC2

Whenever I want to save all attachments of a message (using "Save all"), I end
up with many download progress dialogs, one for each of the attachments. I then
need to close all those dialogs one by one which is cumbersome.

A "Save all" should only have a single progress dialog IMHO.

(Also, why does the dialog talk about downloading, why does it have a "keep
window open after download is complete", a "pause" button? I'm only saving
attachments, not downloading anything (it looks like a browser download dialog,
not a mailer "saving attachments..." progress dialog)

Reproducible: Always
Steps to Reproduce:
1. verify that you have "keep window open after download is complete" active
2. send yourself a message with 10 attachments
3. on reception, select "save all"


Actual Results:  
For a mail with 10 attachments, TB will display 10 download/save progress
dialogs, which I then have to close one by one.


Expected Results:  
There should only be a single progress dialog for all the attachments.

After saving all attachments, the dialog should probably only propose "close"
and "show file(s) location". A "run all" makes no sense IMHO since it would
clutter the screen with lots of new windows.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
It seems that with Thunderbird 1.5 beta 1, things have improved: sending myself
a mail with many attachments doesn't leave as many "100% of <file> saved"
dialogs on my screen as it used to.

It seems that the progress dialog has changed, and it doesn't stay on screen for
files of type .txt/.xml/.zip or without an extension (those are the ones I
happened to test with).

However, the problem persists at least for files of type .exe. If I send myself
a mail with 3 executables attached, I get the "100% of <file> saved" for each of
them, and have to close all 3 progress dialogs manually (assuming the "Keep this
window open after download is complete" option is still set).

It is the same dialog you get when you right-click->save... on one of the
attached .exe's.
*** Bug 338449 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 377618
Severity: enhancement → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
QA Contact: front-end
Hardware: PC → All
Summary: save all attachments should not display a progress dialog for each file → Save All Attachments should not display a download window for each file
Version: unspecified → 2.0
Assignee: mscott → nobody
I think this no longer applies and could be closed as wfm.
Wayne?
thx
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.