Treeitems can't be selected when not all treecol elements have an id attribute

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: michali.sarris, Assigned: janv)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041102 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041102 Firefox/1.0RC2

When not all treecol elements have an id attribute, the treeitems can't be selected.

Also will the label value of first treeitem wich is under a treecol (from left
to right) with an id attribute be used for all the other treeitems wich are
under a treecol with no id attribute. This is demonstrated in the file provided
in the URL field.

You can see three trees in this file.

-In the first no treecol has an id attribute. So no items can be selected and
all cell contain the value of the first cell in the row.

-In the second i gave the first treecol an id attribute to show that then the
second treecell label value will be used for all the cell except the first one.
This one will keep its value. Also here no item is selectable because not all of
the treecol elements have an id attribute.

-The third tree is working as it is supposed to. Because all treecols have an id
attribute.

That's about it.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
*** Bug 267469 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

14 years ago
This has been fixed in Mozilla 1.8. AFAIK there are no plans to backport it to
aviary branch, that is, to Firefox 1.0
Marking worksforme, since it does (on trunk).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.