launches an unwanted popup window

RESOLVED DUPLICATE of bug 258487

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 258487
14 years ago
14 years ago

People

(Reporter: Kevin, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

Through some clever javascript, these folks have managed to sneak a popup by the
popup blocker. An entirely different implementation of a popup sneaking through
the blocker can be found by visiting www.barbie.com (which redirects to
barbie.everythinggirl.com)

Reproducible: Always
Steps to Reproduce:
1. Visit www.burn4free.org 
2. Visit www.barbie.com
3.

Actual Results:  
two different style popups launched. The one at burn4free appears to be a
handcrafted one; barbie.com's appears to be a more traditional one.

Expected Results:  
blocked the popups
The first one is *not* a popup. The easy way to tell the difference is just to
close the tab/window: if it's still there, it was a popup, if it's gone, it was
a web page fouling it's own nest. If they instead chose to start with an image
ad with a link to click to get to the actual content, it would be no different,
and I know plenty of sites that use the exact same script as that to do actual
content, so "movable divs with an X in the upper right" can never just be
prohibited (though there are bugs around to stop the more aggressively flashing
and jumping ones).

The second one, with Flash triggering a popup, is actually fixed, but only via a
hidden pref that you have to create. With privacy.popups.disable_from_plugins
set to 2, Barbie has to beg permission to open a popup.

*** This bug has been marked as a duplicate of 258487 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.